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1. INTRODUCTION 
 

BEXEL Manager is BIM management software solution which, by its capabilities, is the main support for 

traditional workflow during all phases of the project. Bexel Manager allows better understanding and 

improvement of 3D BIM model as well as optimization of costs and workflows. In addition to geometric data 

3D BIM model in BEXEL environment also contains non-geometric elements data such as properties, 

parameters and other important project related data. BEXEL Manager supports open BIM access with ability 

to exchange files created in different BIM authoring tools.  

To import the project into BEXEL Manager, BX3 file format from Autodesk Revit or IFC file format from other 

authoring tools are used. The Project generated in BEXEL Manager has BESLN file format. Exporting and 

exchanging data between users of BEXEL Manager is possible through BXF file format.  Such data includes 

selection sets, quantity takeoff, cost and schedule data, clashes and many more.  

The main features of BEXEL Manager software solution are: 

 3D model view in intuitive and user-friendly interface with advanced visualization of 3D model (real 

time model navigation, walk-mode, enhanced visualization using scenes, views and animations); 

 3D Model review with ability to filter and group model elements by various criteria, advanced 

element search and filtering, color coded element breakdowns; 

 Easier coordination of the project using 3D BIM Features such as Quantity takeoff (QTO), Clash 

detection, Custom Breakdowns, Custom Quantity takeoff and Clash detection reports;  

 Collaborate all stakeholders to achieve intelligent information sharing. Interoperability with other 

BIM software solutions through IFC and BCF file formats (IFC import/export, BIM Collab); 

 Create and manage Schedule and Schedule Animation (4D BIM Model), import/export multiple 

schedules from various sources, manage schedule tasks, manage construction methodologies and 

schedules, smart mapping model objects with schedule tasks, filter and sort schedules by any model 

property, schedule comparisons, update schedule progress, visualize 4D sequence using custom 

color schemes; 

 Create Schedule Animation with Costs (5D BIM Model), assign labor, equipment, material resources 

and their costs to tasks, tracking planned and actual cost, view and export cost reports such as other 

5D BIM Features; 

 Centralized, model-based 6D facility maintenance planning and tracking, containing equipment data, 

documents, specifications and materials (6D BIM Model). Maintenance up-to-date facility and 

equipment data including user manuals, equipment specifications, maintenance schedules, 

warranties, cost data, upgrades, replacements, damages and deterioration, maintenance records, 

manufacturer’s data, and equipment functionality. 

The following chapters, complemented with video materials, will explain BEXEL Manager’s features and 

workflows. All Procedures are explained briefly and unambiguously and they are divided into steps (marked 

with arrows). Pay attention to Notes and Warnings that are clearly highlighted in the text. Shortcut for the 

right click is RC. 

1.1. INSTALLING BEXEL MANAGER 

BEXEL Manager installation starts by double click on BEXEL Manager Setup application *exe. 

The system will ask for permission to install new application, therefore you need to respond on the system 

question (Do you allow this app to make change to your device?) by selecting option YES. Afterwise just follow 

the typical installation process.  
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        → Wait for setup preparation → Select option Next on setup welcome screen→ After read License 

agreement and acceptance of EULA ( I accept )→ Click on button Next → In newly opened dialog window 

select type of the installation Complete ( or Custom ) and select Next → For starting selected setup  - choose  

Install → After completion of the process, select Finish.  

This process completes the installation of BEXEL Manager on your computer and you'll notice the BEXEL 

Manager shortcut icon            which you can use for starting the software. 
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The Semple project comes with software installation and it contains examples of basic program features. 

The Semple project contains examples of scenes and animations, smart selection sets, quantity takeoff, 

Custom Breakdown, Uniformat and Masterformat cost databases, Cost, Clash detection, methodology and 

zones for schedule crating, as well as 4D Simulation. How to use Semple project will be describe below. The 

Semple project is located at C:\Program Files\BEXEL\Bexel Manager 10\Samples\Bexel Sample Project. 

2. BEXEL MANAGER ENVIRONMENT 
 

2.1. START-UP AND PROJECTS 
 

2.1.1. APPLICATION START-UP  
Open the application by double-click on the BEXEL Manager shortcut icon. As we don't have an active project, 

interface is presented with empty viewport. If we want to open a new project just click the X button located 

in the upper left corner. Drop-down window opens with commands such as New, Projects and Versions, 

Open, Close Project, Save, Save As, Exchange and Quit. 
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2.1.2. CREATING NEW PROJECT 
→ Select the button New. → The Add New Project opens, where we define the project name and 

version. → Click the Choose button and 

select the BX3, BESLN or IFC file format. → 

Finish the procedure by clicking the OK 

button.  

2.1.3. OPPENING SAMPLE PROJECT 
→ Select the button New. → The Add 

New Project window opens where we 

define the project name and version. → 

Click the Choose from Samples button and 

select the Sample Project file which comes 

with the software. → Finish the procedure 

by clicking the OK button.  

 

Note: If we want to open two projects at the same time, we have to run two instances of BEXEL Manager.  

  

 

2.2. PROJECTS AND VERSIONS 
 

The Manage Projects and Versions window gives us review of all projects we have created. As we create a 

New project, we create a project Folder for the first time. All other versions of the same project are saved in 

that Folder. The Manage Projects and Versions window activates when we click the X button in the upper left 

corner of the screen, then selecting the Projects and Versions. The existing project folders and versions could 

be deleted, copied, updated or transferred.  
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2.2.1. COPY PROJECT VERSION  
→ Command Projects and Versions → The Manage Projects and Versions window opens. → Select the 

project version you want to copy. → Click the Copy button. → The Create a Copy window opens. → Name 

the new copy. → Finish the procedure by clicking the OK button.  

2.2.2. DELETE PROJECT VERSION  
→ Command Projects and Versions → The Manage Projects and Versions window opens.  → Select the 

project version you want to delete. → Click the Delete button.  → Finish the procedure by clicking OK. 

2.2.3. SAVE PROJECT VERSION  
→ Select the Save command.  

2.2.4. SAVE AS PROJECT VERSION  
→ Select the Save As command. → A new project version will be saved in the original project folder. 

 

Note: The latest created project version opens automatically. If we want to open the previous project version, 

click on the application button in the upper left corner and choose Project and Versions. In the Manage 

Projects and Versions window, the project folder contains all created versions of the project.   

 

Note: If the project contains only one version, we have to be careful not to delete it. If we delete the only 

existing version of the project, we delete the whole entire project. There is application warning about this 

action as well.  

 

2.2.5. PROJECT VERSION RENAMING 
→ Software interface → Select the Manage tab, → Select the Rename Project command. We successfully 

renamed the active version.   

 

Note: We can check which version of project is actually renamed, just go to the Manage Projects and Versions 

window where we have list of all existing projects and versions, sorted in appropriate folders. 

 

2.3. PROJECT TRANSFER AND PROJECT IMPORT 
 

2.3.1. PROJECT TRANSFER 
→ Select the Projects and Versions command. → The Manage Projects and Versions window opens. → 

Select the version you want to forward. → Select the Open Containing Folder button. → Send the selected 

version. 

 

Note: Project folders are stored at C:\Users\Documents\Building Explorer X Projects where X presents the 

current software version. 

 

2.3.2. PROJECT IMPORT 
→ Select the Projects and Versions command. → The Manage Projects and Versions window opens. → 

Click the Import button. You can select the BESLN file format. 
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2.4. PROJECT DATA EXCHANGE 
 

BEXEL Manager allows multiple users to work on the same project at the same time. If we want to transfer 

project data between two or more users, such as selection set, animation or cost data, we can use the 

Exchange module. This process won't create new project version, it just updates the current version. 

→ Select the Exchange command. → Export or Import → The Exchange Wizard window will open. → 

Select what you want to import or export.→ Finish the procedure by clicking the OK button.  

 

 

 

2.5. PROJECT UPDATE 
 

During its life time, the project is constantly changing, complementing and upgrading. In order to develop 

project and create different analysis, BEXEL Manager offers the option of easy and flexible project update. If 

we want to update our project, all active projects should be closed before we start update. Activate the 

Projects and Versions window and select the project version we want to update.  BX3 or IFC file format is 

used for updating model. 

→ Select the Project and Versions command. → The Manage Projects and Versions window opens. → 

Select any project version that you want to update and rename it, that’s the name of the new project 

version.→ Click the Update button. → Choose the file we are going to use for updating selected version of 

existing project.→ The Match Sources window opens. → In the Match to Source column select the New. → 

The New Source Name window opens where we define the name of the new source. → Finish the procedure 

by clicking the OK button.  If we want to update one of existing source files in the project, instead of choosing 

new source, we should match new source file with one of the existing. 
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Note: Open the project version you’ve just created. We can check how many imported models our project 

version contains, go to the Manage tab, click the Sources command. 

 

3. TOOLBAR VIEW 
 

3.1. RIBBON VIEW 
 

After project startup, 3D view of the model is shown in the center of the screen by default. The upper part 

of the application interface has ribbon with various tabs such as Manage, Selection, Clash Detection, 

Schedule, View, Cost, Reports and Settings. When we activate any of the tabs, the ribbon is displayed that 

contains tools within the selected tab. The user interface contains several palettes on the right, left and the 

bottom part of the screen. Each of these palettes contains large number of sub-forms with different tools. 

Visibility of individual palettes, menus and tools can be adjusted using the View tab, which will be explained 

below. 
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3.1.1. ACTIVATION OF SPECIFIC VIEWS 
Command View → Select one of the view types, such as 3D Perspective View, 3D Color Coded View, Schedule 

View or Level Map. → By clicking the icon, each view type is activated or deactivated. Active view types are 

displayed on the toolbar above the main 3D viewport and on the Other Views button, which is also included 

in the View tab. 

3.1.2. SETTING THE PALETTE VISIBILITY 
Command View → Select the Windows button. → A list of four palette groups opens. → Toggle their 

visibility by checking/unchecking them. 
 The first group of palettes presents different view types of the project, such as 3D Perspective View, 

2D/3D Orthographic View, Schedule View, 3D Color Coded View, etc.  

 The following group is in the left part of the screen. We use it to view, organize or create different 

breakdowns of elements which is very useful for further analysis and desired visualization. These are 

Building Explorer, Selection Sets and Custom Breakdowns. 

 The third palettes group contains Quantity Takeoff, Schedule Editor, Schedule Animation, Clash 

Detection and Animations Form and it is located at the bottom of the screen. 

 The last palettes group contains tools which show us all information about selected 3D BIM model 

elements. It is located in the right part of the screen. These are the Properties, Selection Info, Level Map, 

Documents and Materials.  

Above is where the pallets are located by default. We can move each of the palette group and place it 

somewhere else within the software interface. 

3.1.3. SETTING UP DEFAULT SOFTWARE INTERFACE 
When we want to restore the original appearance of the software interface, select the Reset Layout 

command in the View tab. If we are satisfied with the appearance of the program interface and the layout of 

individual tools, Layout can be saved and exported, and then used in another project. 
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3.2. THE MAIN 3D VIEWPORT  
 

The main 3D model viewport is located in the middle of the screen by default. The toolbar above the main 

display window shows various types of views, such as 3D view (perspective), 2D/3D Orthographic view, 

Schedule Viewer, 3D Color Coded View, Orthographic Color Coded View and Assigned/Unassigned. These 

tools allow different model representations, which will be explained later. When we start a new project, 3D 

Perspective View is activated by default. When we open the model that we have already worked on, the last 

active view will be opened. 

3.2.1. SIMULTANIOUS REPRESENTATION OF A MODEL IN TWO DIFFERENT WAYS 
3D View → RC → Select the New Horizontal Tab Group command or New Vertical Tab Group command.  

To reset view to previous state, activate the menu by right-click on the selected view and select the Move to 

Previous Tab Group button. 
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3.3. 3D VIEW TOOLS 
 

The toolbar for the 3D view is located above the top edge of the 3D viewport. It contains various tools that 

we can easily activate by selecting them. Some tools appear in other palettes aswell, where we activate them 

in the same way.   

3.3.1. ASPECT RATIO TOOL 
This is a tool for adjusting the aspect ratio of the presentation field. Aspect ratio is also used for taking 

screenshots. By default, this is set to free aspect, but there are also options for fixed aspect ratio like 16:9, 

3:2, 4:3, 1:1 and custom. 

3.3.2. NAVIGATION TOOL 
This is an individual selection that allows selecting the individual 3D BIM model elements. If we want to add 

elements to any selection, hold down the Ctrl key and click on elements. For excluding the elements from 

the selection, hold down the Alt key and select the elements we want to exclude. 

3.3.3. SELECTION TOOL 
This is a rectangular selection tool. When we mark elements from left to right, we select only those elements 

that are completely in the rectangle of selection. When we mark elements from right to left, we select all 

elements, although they are only partially affected with selection rectangle. Commands such as New 

Selection, Add to Selection, Intersect from Selection or Subtract from Selection, allow us to make further 

choices of selection within the existing group of selected items. 

3.3.4. RENDER MODE TOOL 
This is a tool that allows different scenes appearance, such as Wireframe render mode, Shaded render mode 

or Shaded & Edges render mode. Using the Render mode tool, we apply changes to the entire model. 

3.3.5. OPACITY TOOL 
This is a tool that allows us to determine the transparency of the whole model. Opacity values are given from 

10 to 100 percent. The Reset command allows us to reset the original value of the model opacity, while the 

Reset Full command sets the full visibility of the model regardless of the previous settings.  

3.3.6. PREDEFINED VIEW TOOL 
We can review the project with predefined tools that can help us understand elements position in the project, 

quickly and accurately. Especially useful type of predefined view is Top 2D / 3D axonometric view. If we 

isolate a particular floor using this view, we can get a separate building floorplan. 

3.3.7. VIEW CUBE TOOL 
The view cube is located in the right corner of the 3D viewport. The cube sides are named by standard view 

types such as Top, Back, Front etc. By selecting any cube side, the same side of the 3D BIM model is displayed. 

 

3.3.8. FIELD OF VIEW (FOV) TOOL 
We can define the Field of View when 3D view is active, using the FOV tool. This is the field of observation, 

which is determined by the angle of view and the focal length in millimeters. These parameters are 

interdependent. The smaller focal length is, the more amplified perspective is. 
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3.3.9. CURRENT VIEW SCREENSHOT TOOL 
This tool allows us to create screenshot of the current view. The screenshot can be exported in BMP, JPG, 

PNG or GIF format. When we click on the screenshot icon, the Screenshot Configuration window opens and 

it contains tabs General, Level Map and Additional Information. 

GENERAL TAB 

 Resolution → Dimensions of the image can be specified.  

 Keep Selected Elements Highlighted → If checked, the selected highlighted elements remain colored as 

they are in viewport. 

 Override Visual Settings, Override Background Color or Transparent → If checked, we can override 

background color or make it transparent. 

 Draw Grid and Axes → If checked, grids and axes will be included in the screenshot. 

 Preview screenshot → If checked, the screenshot preview will be automatically opened after saving the 

image in the desired location.   

 

LEVEL MAP TAB  

The Level Map tab gives us option to display level map in our screenshot. It contains options for position and 

size, background color, frame, font settings and display cursor. It will show level that is selected in Level Map 

palette which is in the right side of the user interface by default. 

ADDITIONAL INFORMATION TAB 

We can add additional information on our screenshot such as clash information or custom text. Position, 

background, frame and font settings for additional information are in this tab. 
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3.4. NAVIGATION IN THE 3D VIEWPORT 
Navigation in the 3D viewport allows us to preview 3D BIM model in different ways. 

3.4.1. PAN MODE TOOL 
This is a tool that allows us to move the model in certain directions, such as left, right, up and down. We can 

activate it in few different ways: 

 By pressing and holding the scroll button. 

 Select the tool icon in the 3D View toolbar. → Pan Tool → Click and hold the left mouse button. This 

allows us to move the model in all directions.  

3.4.2. ZOOM MODE TOOL 
To zoom in and out we can use the Zoom Tool. This tool can also be activated in different ways: 

 By scrolling up (this way we zoom the model in) or down (this way we zoom the model out). 

 Select the tool icon in the 3D View toolbar. → Use the keyboard, the up-arrow key (this way we zoom the 

model in) or down-arrow key (this way we zoom the model out). 

 Select the tool icon in the 3D View toolbar. → Click the left mouse button and drag up (this way we zoom 

out the model) or drag down (this way we zoom in the model).   

3.4.3. FIT TO BOUNDS TOOL 
This is a useful tool that enables optimal zoom of the project or selected elements. We can use it in several 

ways: 

 Select the element → Select the tool icon in the 3D View toolbar. 

 Select any element or project. → Double click the mouse wheel. 

3.4.4. ROTATE MODE TOOL 
This tool allows the rotation of the 3D BIM model. It can be activated in two ways. 

 Click on the tool icon in the 3D View toolbar. → Press the left mouse button and hold down. 

 Activate the Navigation regime tool. → Hold down Ctrl and left mouse click at the same time.  

3.4.5. SET ROTATE TYPE TOOL 
Set rotate type tool allows us to determine the type of rotation. In the drop down menu we can select the 

type of rotation. 

 About Camera Eye → Camera rotates around the axis.  

 About Camera Object → Camera rotates around the selected object.  
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3.5. CONTEXT MENU 
 

The context menu is activated by right clicking in the 3D 

viewport. The menu opens and it includes four groups of 

commands. The first group of commands allows selection of 

elements based on different parameters. The second group 

allows us to show/isolate specific elements. The third group 

allows us to change the elements appearance. The last group 

includes commands that can change the look of the 

background of the viewport. 

3.5.1. SELECT COMMAND 
This option allows us to select elements in different ways and 

using some predefined criteria. 

For example: 

 Select the element. → RC → Select → Entire Family, 

Category. This will select all the elements of the same 

family/category as previously selected element. 

 Canceling the command → Esc key. 

Other options include selecting visible/invisible elements, selecting by color or selecting previous/next 

selection. 
 

3.5.2. HIDE COMMAND 
We select this option when we want to hide elements, whole family or category of currently selected 

element. 

 Select the element.→ RC → Hide → Selected element, Unselected elements, Entire Family etc. 

 Canceling the command → Undo Visibility Change or Ctrl+Z   

 

 
 

3.5.3. ISOLATE COMMAND 
This is a tool that allows us to isolate selected elements, or whole family or category of currently selected 

element. 

 Select the element. → RC → Isolate → Selected Elements, Entire Family, Entire Category  

 Canceling the command → Undo Visibility Change or Ctrl+Z 
 

3.5.4. ISOLATE WITH DIM COMMAND  
This is the type of isolation of a particular element, where we can arbitrarily determine the visibility and 

transparency of other elements.  

 Select the element. → RC → Isolate with Dim → Wireframe, Shaded, Shaded with Edges → We define 

the transparency of elements, which don’t need to be expressed, in percentages. → Selected elements  

  Canceling the command → Undo Isolate with Dim or Ctrl +Z  

Warning: Isolate with Dim command can cause problems if you take a few extra steps after activating this 

command, because then you can not cancel it. It is recommended that you immediately cancel the 

command after use. 
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3.5.5. VIEWPORT CONFIGURATION 
Viewport options allow us to configure graphical settings for background, grid and the way objects and object 

selections are represented. We can also configure options for element tooltips. When we activate the 

Viewport options, it has two tabs: Background & Grid and Tooltip Options. 

Viewport options are activated in the following way:  

RC in the presentation field. → The context menu opens where you select the Viewport Options item. → The 

Configure Viewport window will open.  

BACKGROUND & GRID TAB  

This tab allows us to change the background colors or set the background image, change the visibility of the 

network, etc. 

 GRID OPTIONS → RC → Viewport Options → The Configure Viewport window will open. → Select the 

Background & Grids tab. → Check the checkbox next to the option Grid.  

 BACKGROUND COLOR CHANGE → RC → Viewport Options → The Configure Viewport window will open. 

→ Select the Background & Grids tab. → In the Background section, choose whether the background 

will be monochromatic (Constant Color) or polychromatic (Gradient). → Choose the background color.  

 IMPORTING JPG FILE AS BACKGROUND → RC → Viewport Options → The Configure Viewport window 

will open. → Background & Grids → Check the checkbox next to the option Sky Dome (The imported 

image must be in high resolution). 

 CHANGE COLOR OF SELECTED ITEMS → RC → Viewport Options → The Configure Viewport window will 

open. → Select the Background & Grids tab. → Structure.  

 CUBE AND COORDINATE AXES → Select the Background & Grids tab. → Gizmo → Choose whether you 

want cube and axis to be visible or not. 
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TOOLTIP OPTIONS TAB  

The Tooltip provides basic information that appears next to the cursor when we move it over the certain 

element. We can determine the content of this information or we can completely turn them off. 

 TOOLTIP OPTIONS → RC → Viewport Options → The Configure window will open. → Select the Tooltip 

Options tab. → We define the visibility of the Tooltip by checking the Use Tooltip checkbox.  

 In the Parameters window, we can define which element parameters will be displayed.  

 We have the ability to specify the Tooltip location, which can be shown in the form of a fixed frame or 

floating window. If we choose to see the item information in a fixed frame, we can find additional options 

to set the location of tooltip window.  

 By clicking the Reset button, we switch back to the default settings.  

 
 

3.6. MODEL VISUALISATION 
 

In this chapter we will talk about changing the visual characteristic of the model, setting colors of individual 

elements, families and categories and the usage of the Render Type command. 

3.6.1. COLOR EDITING 
 APPLYING A NEW COLOR → Select the element. → RC → Change Color → Select the Selected elements 

command. We can specify color from the palette or set custom color.  

 APPLYING THE EXISITING COLOR → Select the element. → RC → Change Color → Select the Pick Color 

command.→ Select the element we want to color. → RC → Change Color → Paste Color 

 To cancel the command, use the Ctrl+Z keys or the Undo Color Change command. This way, it is possible 

to apply existing colors to entire families or categories of elements.  

 APPLYING THE DEFAULT COLOR → Select the element. → RC → Change Color → Reset to Default → The 

element’s color changes back to the default color.  

 
 

3.6.2. CHANGE OPACITY 
 Select the element. → RC → Select the Change Opacity command.→ Choose the transparency level which 

is in percentage (10-100 %).   

 To cancel the command, use the Ctrl+Z keys or the Undo Color Change command.  
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Warning: The difference between the Change Opacity command in the context menu and the Opacity 

command located in the 3D View toolbar is that the command in 3D View toolbar determines the 

transparency of the whole project. Change Opacity command from the context menu allows us to change 

the transparency of selected elements. 

 

3.6.3. RENDER TYPE 

 Select the element. → RC → Select the Render Type command. → Then specify the display type: 

Wireframe, Shaded or Shaded with Edges. → Choose between options such as Selected elements, 

Unselected elements etc. 

 To cancel the command, use the Ctrl+Z keys or the Undo Color Change command. 

 

 

Warning: The Render Type command is located in the context menu and the Render mode command is 

located in the 3D View toolbar. The difference between these two commands is that the Render Type 

command applies changes on any selected elements while the Render mode tool allows us to apply changes 

on the entire project. 
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3.7. TEXTURE APPLICATION 
 

BEXEL Manager allows us to apply textures to model elements. It should be noted that the image we use as 

texture must be in the 1: 1 ratio and the optimal image size should be at least 1024 x 1024 pixels in JPG 

format. 

3.7.1. ADDING TEXTURE 
Select the elements you want to apply the texture on. → Select the Manage tab. → Click the Texture Editor 

button. → Select the Project folder in the Textures and Mappings list → Click the Add Texture button. → 

Select the desired texture and in the Add Texture window, name the file. → Click the Add Mapping button. 

→ Define the material name and confirm the selection. → Complete the procedure by clicking the OK button.  

3.7.2. REMOVING TEXTURE 
Select the element. → RC → Click on the Texture Mapping command on the Manage tab. → Choose the 

Remove Texture option.  

3.7.3. REMOVING TEXTURE FROM THE LIST 
Select the texture on the list. → RC → Select Delete or Delete Texture.  

The Global Textures Folder is where all the textures are stored by default.  It is located on the following path:  

C:\Users\%UserName%\AppData\Roaming\BEXEL\Bexel Manager 10\Textures. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Warning: The undo command (Ctrl+Z) does not work with this tool. If we want to remove texture from 

element just follow the next procedure. → RC → Texture Mapping → Remove Texture. This removes all 

textures from the element. 
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3.7.4.  TEXTURE EDITING  
 Select the element. → Choose the Manage tab. → Click on the Texture Editor icon. → Then activate the 

Edit Mapping button. → Finish the procedure by clicking the OK.  

 Select the element. → RC→ Choose the Texture Mapping tab. → Go to Mapping → Click the Edit Texture 

icon.  

3.7.5. TEXTURE APPLICATION UNDER PREDEFINED MATRIX 
Select the Manage tab. → RC on the Texture Editor button. → Choose the Predefined Texture Mapping 

command. → Import → Select the XLSX file format. → Open the Quick Texture Mapper window. → Click on 

the Apply All button. All files must be sorted in the Global Textures Folder beforehand. 
 

3.8. WALK MODE TOOL 
 

Walk mode is a navigation tool. It allows us to observe the object from a 

human perspective. First, click on the walk mode tool icon located in the 

3D View Toolbar. Then choose the plane of the movement. Only floors are 

recognized as movement planes. When navigating, you can use the level 

map tool for easier navigation through building level. 

 Moving left, right, forward and backward. → Using the arrow keys on 

the keyboard.  

 Looking up or down. → Using the mouse wheel.  

 Looking around 360 degrees → Holding the left mouse button.  

 Walk through the door or down the stairs. → Left mouse button + 

arrow keys on the keyboard. 

 It is not possible to go through walls, expect when using a level map 

tool. 

 

3.9. SHORTCUTS 
 

There are pre-defined shortcuts for each command 

in the program. The shortcut list is displayed by 

double-clicking the letter C.  

 

3.10. DIMENSIONS AND ANNOTATION 

TOOLS 
 

3.10.1. MEASURE DISTANCE TOOL  
This is a tool for measuring the dimensions of 

elements or distances between elements.  

Click on the measure distance tool icon in the 3D 

View toolbar. → Select the distance you want to measure. 
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3.10.2. SPOT ELEVATION TOOL  
This is a tool for measuring the height of the selected point relative to the 0.00 reference point in the model. 

It will also show Storey-Relative elevation based on the selected reference storey, as well as absolute 

elevation if such was defined in authoring software from which model originated.  

Click on the tool icon in the 3D View toolbar → Select the Spot elevation icon. → Choose the point to measure 

elevation. 

 

 

 

 

 

 

 

 

 

 

3.11. SECTIONING TOOL 
 

The section plane tool is a very useful tool that allows us to create different cross-sections of the model. It is 

possible to set the plane of the cross-section in parallel with X, Y or Z-axis. We use this tool for a detailed 

overview of the quality of the model as well as the visual presentation of the project.  

3.11.1. CREATING A SECTION PLANE 
 Select the View tab. → Click on the Enable Sectioning icon. → The menu for editing the section plane level 

will open. → Click on the Active Planes button. → Choose the section plane named Plane 1. → Choose 

the position of section plane in the model. 

 

3.11.2. EDITING A SECTION PLANE 
 Click the arrow next to the Edit button and choose the cross-section you want to edit.   

 The Tab key changes the orientation of the section plane.  

 The Space key changes the orientation of the vector and thus the direction of the section plane itself. 

 The Enter key enters the pre-set section plane. At the same time, we can store six horizontal section 

planes. 

 Moving the section plane along the vector. → Select the vector and determine the position of the section 

plane in parallel to the direction of the vector. 
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4. BUILDING EXPLORER PALETTE  
 

Visibility of all palettes of user interface 

can be set by clicking Windows icon in 

View tab. We are going to explain the 

Building Explorer palette which is located 

on the left side of the screen by default. 

Building Explorer palette shows the 

breakdown of elements by their 

categories. It contains four main tabs: 

Elements, Spatial Structure, Systems and 

Workset Structure located in the upper 

part of the palette.  

If we select some elements in any tab, 

they will be highlighted in all type of 

viewports such as 3D display, 2D / 3D 

orthographic view or Schedule Viewer. 

Circles in front of the names of element 

categories indicate visibility of the 

elements in the viewport. The yellow 

circle indicates that all elements of 

category are displayed in the viewport, 

an orange circle indicates that only 

certain elements of the category are 

displayed while others are not displayed 

in the viewport. White circle indicates 

that all elements of category are hidden 

in the viewport. 

 

4.1. ELEMENTS 
  

The Elements tab contains the list of all elements in the project. The elements are sorted in categories and 

each category contains certain families (families are subgroups of categories). Each element belongs to 

corresponding family according to common characteristics, such as dimensions, material, finishing, etc. 

Distribution of elements into families and categories is done in the authoring software in which the model 

was originally created. 

 

4.2. SPATIAL STRUCTURE  
 

The Spatial structure tab represents element breakdown by buildings and building levels. Spatial structure is 

inherited from the authoring software where the model was originally created. BEXEL Manager has a tool for 

moving elements to different levels and buildings as well as option of spatial structure reorganization if it is 

necessary.  
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Warning: Editing individual elements by floors and objects. → Activate the Manage tab. → Select the Edit 

Spatial Structure tool. → Move to Building or Storey.  

 

4.3. SYSTEMS 
 

The System tab represents the elements breakdown by MEP Systems that are also inherited from authoring 

software. In Bexel Manager we can move elements in or out of systems but we can not create new systems. 

To move elements in or out of systems click on the drop-down arrow next to the Systems button in the 

Manage tab. Two options will be displayed: Add Elements to the System and Remove Elements from System. 

 

4.4. WORKSET STRUCTURE 
 

The Workset Structure tab allows the user to view the elements breakdown by worksets that are defined in 

authoring software such as Revit. We can organize project elements in worksets such as architecture, 

structure, site, sewage, water supply, etc.  Workset structure is inherited from authoring tool and it is not 

editable in Bexel Manager. 

 

5. PROPERTIES PALETTE 
 

In this chapter we will talk about group of palettes 

on the right side of the screen. These palettes are 

Properties, Selection information, Level map, 

Materials and Documents, located in the lower part 

of the palettes group. They are intended to provide 

information on selected elements at different 

levels. 

All properties of selected elements are displayed in 

Properties palette and they are grouped by their 

corresponding property sets.  

In the upper part of the properties palette we can 

see tabs: Properties, Favorite Properties, Relations 

and Sub-element Properties. 

We can add properties to favorites by right clicking 

on property and choosing option Add to Favorites. 

They will be displayed in the Favorite Properties 

tab. 

In Relations tab we can see with which elements 

the selected elements are in relation. For example, 

if we select windows this tab will show walls they 

are attached to. 

In Sub-element Properties tab, we can see sub-elements of composite elements and their characteristics. For 

example, Layers of multilayered floors or walls with their thicknesses and materials. 
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5.1. ADDING A NEW PROPERTIES 
 

In Bexel Manager we can easily add new properties and define new property sets. 

Select the element. → Select the Property palette. → Click on the Property drop down button in the top right 

corner. → Click on the New button and specify the name and property set in which the property will be 

placed. → Define property Type. → Define Unit. → Add constant value or expression (Fx button). → Finish 

the procedure by clicking the OK button. → A new attribute for selected element will appear in the group 

that we have previously defined. 

Note: By clicking on Fx button new form will open where we can define mathematical formula using basic 

mathematical operant. We can also refer to some other existing properties for selected element and use 

them in formula. 

 

Warning: Bexel Manger will not let us create two properties with the same name even if they are in different 

property sets. 

 

5.2. EDITING A PROPERTIES  
 

Select the element. → Select the Property palette. → RC on the selected property. → Select the Edit 

command. 

Note: The BEXEL Manager allows us to add a new property to any element or to modify the existing property 

that element has from the authoring software in which the model was originally created. It is recommended 

that the editing properties as well as adding new properties should be done in software in which the 3D 

model was originally created. When properties are changed or added in BEXEL Manager, they remain 

unchanged in the original source file. When we update our model, we rewrite the element's properties from 

the original software again.  

 

5.2.1. SELECT ELEMENTS BY VALUE COMMAND 

We can easily select elements that have same value of certain property. 

 
Select the element. → Select the Property palette. → RC on the selected property. → Select the Select 

Elements by Value command. → Choose All or Only Visible option. 

5.2.2. COPY TO CLIPBOARD COMMAND 
This command allows us to copy the value of element’s property to clipboard. 

Select the element. → Select the Property palette. → RC on the selected property. → Select the Copy to 

Clipboard command. → Open the desired program. → On an empty sheet copy the values using the Ctrl+V 

keys.  
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5.2.3.  VIEW VALUES OF THIS PROPERTY COMMAND 
Choose the desired property, select it and click on it with the right mouse button. → Select the View Values 

of Property command. → The Property Values window opens. → If we want to select all listed values, we use 

Ctrl+A. → Select the Copy to Clipboard command. → Open the desired program. → On an empty sheet copy 

the values using the Ctrl+V. 

 

The Property Values window has option to filter 

listed values by All Categories, This Category, 

Selected Elements. If we check Only visible 

command, visible elements in main viewport 

which have this property will be listed in 

Property Values window. 

5.2.4 PROPERTY DISPLAY FILTER 
Select the element. → Select the Property 

palette. → Select the Options and Filters 

command where we define which property will 

be displayed. 

 

6. SELECTION INFO PALETTE  
 

The Selection Info palette is part of the palette 

group which is also located in the right side of 

the screen. It contains options Select Elements, 

Select Structure and Structure. This tool allows 

us to further inspect our current selection and 

extract some elements from it that we need. 

Structure button has several options for 

selection classification: Spatial, Selection Sets, 

Systems, Worksets an Materials. The items will 

be arranged and displayed in the selection 

information window according to the selected classification. If there are not selected elements, the 

information window is empty. 

 Activate the Selection Regime tool. → Select any part of the object. → the Selection Info window 

contains the information about selection. 

 The Structure command has an option to classify the items by different types of structure. 

 In the bottom of the Selection Info palette the number of selected elements is shown. 

 We can select elements form the list and by clicking Select Elements button we will make new selection 

from previously selected elements. 

 

7. LEVEL MAP PALETTE  
 

This tool can be used in a different situation. It displays the layout of the project at specific level along with 

the camera's position. The camera is displayed as yellow circle, which can be moved to change the viewing 

position in the main viewport. Using camera, we can inspect the whole project, place the camera inside the 
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building on a certain floor and go through the walls of the building. All changes in the Level Map palette are 

immediately projected in the viewport. 

We can choose the Building and the Level (Storey) which are going to be displayed in Level Map window. 

 

7.1. LEVEL POSITIONING ON LEVEL MAP 
 

Choose the Level Map palette. → In the Storey command set the desired level.  

 

7.2. LEVEL MAP DISPLAY OPTIONS 
 

The Level Map Options command is in the upper right corner of the Level Map palette. It contains commands 

the Level Map Options (change the background color, the render type level elements, which category of 

elements will be displayed in the Level Map), the Level Map Ruler options (the shape and the position of the 

ruler in the Level Map) and the Clash options (collision display in the Level Map). 

Choose the Level Map palette. → Activate the Level Map Options command. → Set the background color, 

render type of level elements, select the category of elements which are going to be displayed, etc. 
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8. MATERIALS AND DOCUMENTS PALETTE 
 

8.1. MATERIALS AND DOCUMENTS PALETTE 
 

The Materials palette shows us the information about materials that are specified for certain selected 

element. When we click the Use current Selection button, the name of the selected families and its materials 

are shown in the palette window. You can add new items to a current selection using the Ctrl key. In this 

case, information about the added elements is displayed immediately. 

The Documents palette allows us to attach a 

file to a specific element or group of 

elements, such as display of detail, photos 

from a site, a link to a web page, etc. When 

we click on the Document Registry button, 

the register of all assigned documents 

opens. 

 

8.2. ADDING A FILE 
 

Select the element you want to assign the 

document to. Click the New button. → 

Choose one of the listed file types: File 

Document or Web Document. → The Add 

Linked Documents window will open. → 

Click the Add button and select the desired 

file. → Finish the procedure by clicking the 

OK button. 

Note: Files can be attached to the elements as Embed files in project or Linked files to selected elements. 

The embedded files are integrated into the project. We can access them anytime, but the size of the whole 

project file is increasing. In the second case, we have a link to the documents that could be stored, for 

example, in the cloud. This does not affect the size of the entire project, but if we can not access the server 

where the linked documents are stored, the attached documents will not be available. 

 

9. SCENES AND ANIMATIONS   
 

9.1. CREATING VIEWPOINTS AND SCENES  
 

At the bottom of the screen there are palettes such as Quantity Takeoff, Assemblies, Assigned Items, 

Schedule Editor, Schedule Animation, Clash Detection and Scenes and Animations. First, we are going to 

explain the Scenes and Animations palette. This palette allows us to create the Views, Scenes and Animations. 

The View saves information only about current camera position (viewpoint), while the Scene saves additional 

information about the element’s visibility, transparency, color, render type and camera position. On the left 

side of the palette's window there is a list of all the created views, scenes and animations. When we select 
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any view, scene or animation from the list, we'll see a preview of 3D BIM model on the right side of the 

palette. We can organize list of views, scenes and animations in proper folders. The folder structure could be 

created as we want or could be imported from another version of certain Bexel Manager Project.  

9.1.1. CREATING A VIEWPOINT 
Select the Scenes and Animations palette. → Click the New button and select the View command. → Define 

the View name in the Name section. → Finish the procedure by clicking the OK button.  

A list of existing views is shown on the left side of the palette. 3D Model appears on the right side of the 

palette. By double-clicking on desired View, the 3D model elements appear in the main 3D viewport with the 

same viewpoint which the selected View has.  

Before we create a Scenes, we can change the color of the roof and facade. This can be done using the context 

menu or the Change Color command.  

9.1.2. CREATING A SCENE 
Select the Scenes and Animations tab.→ Click the arrow next to the New button and select the Scene 

command. → Define the name of scene in the Name section. → Finish the procedure by clicking the OK 

button.  

Note: We changed color of some elements after creation of the View and before creating the Scene. When 

we open the scene with double click on it, the 3D model in the main viewport and in the palette’s, window 

looks the same, with changed color of facade and roof. When we open the previous View again, the palette's 

window displays the original look of the facade and the roof, where the color changes are not saved. The 

main 3D viewport shows the model from the same angle as it is shown in the View, but the color of facade 

and roof stays changed because the View saves only the camera position. The scene saves all the changes 

and displays them in the main 3D viewport. Here we have presented the difference between the View and 

the Scene. 
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Warning: In the case where we make multiple scenes and where we change appearance of certain elements, 

such as the facade color, it is recommended to make the scene with the original colors first. After that we 

can create the scenes with individual changes. Otherwise, we can use the Reset to Default Color tool → Select 

the elements. → In the context menu, select the Change Color command. → Then select the Reset to Default 

Color option. 

9.2. CREATING ANIMATIONS  
As we mentioned earlier, we use the Scene and Animations palette for animation creation. The left part of 

the palette contains a list of the views, scenes and animations. When we create new animation frames list 

will be displayed on the right side of the palette and initially it will be empty. A timeline with the standard 

Play command is on the bottom. In the process of creating the animation we orbit around 3D model or 

desired elements of the model, creating Key Frames. In order to create smoot animation, we should pay 

attention to orbit around desired 

elements gradually, corners between 

frames should not be too large because it 

changes the camera path drastically. The 

software automatically merges the 

created frames to animation. The 

Animation is attractive presentation of 

the project, but we can also use it for the 

SCHEDULE development later.  

 

9.2.1. CREATING ANIMATION  

Select the Scenes and Animations tab. → 

Click the New button and select 

Animation. → The New Animation 

window opens.  

 

9.2.2. NEW ANIMATION WINDOW 
 We have to specify the Name of the animation. Animation description in the Description field is not 

necessary to specify.  

 The Frame Rate shows how many images 1 second of animation has. Frame Rate is the ratio between the 

Frame Count and the Duration parameter.  The Frame Count specifies the number of frames and the 

Duration parameter specifies the length of the animation.  The Frame Count and The Duration parameters 

depend on each other. For example, an animation that lasts 60 seconds (the Duration parameter) has 

1800 frames (Frame Count parameter) if frame rate is set to 30. 

 Scale Frame Count option and Scale Duration parameters. → The Scale Frame Count is checked, when we 

change the value of the Frame Rate parameter, the Frame Count is adjusted. The value of the Duration 

parameter will not be changed. Also, if The Scale Duration is checked, the Duration parameter will be 

abused according to changes of the Frame Rate parameter. 

 Scale Frame Rate → If this option is checked, when we change ether the Frame Count and Duration, the 

Frame Rate will also be adjusted.  

 We check the Animation Render State option when we want to save changes of the Render State tool 

between individual frames. For example, in frame 1 the model elements are visible and in frame 2 we 

activate the Wireframe render state option. In frame 3, the elements are completely visible again. The 

animation with changing the model render type of frames and transition from frame to frame is smooth 

and nicely connected. 

 Just created Animation 1 is now shown in the list. If we want to use it later, we have to select it first.  
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9.2.3. CREATE FRAME  
Click the Key Frame button. → Select the New Key Frame option. → Enter the desired name in the Name 

field. → In the Frame field, set the position of the frame in the animation timeline. 

9.2.4. EDIT FRAME  
Select the frame. → RC → Select the Edit Key Frame option.   

9.2.5. UPDATE FRAME  
Select the frame. → RC → Click the Update command. → Choose one of three options: Camera Position, 

Render State Only or Camera Position and Render State.  

9.2.6. MOVE FRAME  
If we move the small squares on the timeline, which illustrate the frames, we change frame's position. If we 

want to change the animation speed, we change the distance between frames. The smaller the distance 

between two frames is, the faster the animation in this segment will be. 

 

9.2.7. COPY FRAME  
Select the frame. → RC → In the menu choose the Duplicate Keyframe command.  

When we want to insert a new frame between e.g. Frames 1 and 2, mark the Frame 1 and select the Duplicate 

option. This way, we copied the Frame 1 and the new frame is inserted between the Frames 1 and 2. This 

new frame can be edited. 

Note: The Show Camera Path command shows the camera path in the animation with a red line. 

9.2.8. EXPORT ANIMATION 
When we are satisfied with the animation, we can export it by using the Export command. We can export 

the entire animation or just a specific part where we can precisely set from which frame, we are going to 

export the animation. If we want to export certain part of created animation, we use the Export custom 

frames tool. We can export the animation in two ways: 

 

 As an image - JPG, PNG, BMP, and GIF format files. You must pay attention to the fact that the number of 

exported images will be equal to the values of the Frame Count parameter. With a Frame Count 600, the 

export of animation will contain 600 images. It is recommended to use the JPG or PNG file format for this 

type of export. 

 As a video – AVI file format. Also, here we have an option to export only a certain number of frames or 

entire animations. We can choose different codecs that can impact video quality and video file size. 
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10. FIND ELEMENTS TOOLSET 
 

Before we introduce the Selection Sets module, 

we are going to explain the Find Elements tool. 

We can activate this tool in two ways: 

 Activate the Selection tab. → Select the Find 

Elements tool. 

 Using the CTRL. 

A window opens where we can activate a 

completely new element's search - New Search 

or element's search within the results of 

previous searches - Search Within Result(s). 

Search can be done on several levels, within the 

entire project or within individual sub-modules. 

 

10.1. SEARCH BY SPECIFIC 

PARAMETERS - EXAMPLE 
 

 Search the Door with the property Width 

greater than 80 centimeters. → 

Select the New Search option. → In the 

Source field, we define Entire Project, which 

means that we will search elements within 

the entire project. → In the Category 

section, select the Door category. → In the 

Visibility section, select the All option. → 

Next, we activate the Advanced section, 

where we determine additional search 

conditions. → In the Properties section, 

select the desired parameter, e.g. Width. → 

Then, we determine the following 

conditions Condition: Greater. → Enter the 

following value: 80. → Then we determine 

the unit of measurement: centimeter. → We 

finish the procedure by clicking the Find 

button. → The Results window shows 

elements that contain certain search 

conditions. The displayed results are the 

total number of found elements.  

In the Selection section we set the conditions when we want to make selection of searched elements 

which are going to be highlighted in main 3D viewport. → Under the Operation section, select the New 

Selection option. → Click on the Select button. → The search results are highlighted in yellow. → Then 

choose the Isolate or Isolate with Dim command to show only search results in the main 3D viewport.  
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10.2. SEARCH MODEL ELEMENTS IN EXISITING RESULTS  
 

Ctrl+F → Select the Previous Search option. → In the Advanced section, select the Width property again. → 

Then determine the following conditions Condition: Grater. → Enter the following value: 120. → Then 

determine the unit of measurement: centimeter. → In the Operation section, select the Subtract from 

Selection option. → Click on the Select button. → Now, doors with the property the Width greater than 

120cm are excluded from the previous selection. 

11. SELECTION SETS PALETTE  
 

The Selection Set palette is located on the left side of the screen. Selection set is a group of elements which 

user defines by desired criteria. The user defines the Name of selection sets as well as their organization. 

There are two types of selection sets. Smart selection set is a group of elements that contains predefined 

rules. The advantage of Smart selection set is that it will be automatically updated after updating the 3D BIM 

model. This means that all new elements will be automatically sorted in the smart selection sets, by 

predefined rules. That is the main difference between the usual Selection sets, where the new elements 

won’t be automatically sorted after update. In that case we should manually sort added elements in Selection 

sets, every time the 3D BIM model is updated. 

Warning: Before we create a New Smart Selection set with defined rules, we have to make sure that there 

are no elements in current selection, otherwise selected elements will also be included in selection set. The 

software alerts us if there are some selected elements, in the Create New Selection Set window, Rules 

section, under Elements. → Include.  

 

11.1. CREATE NEW SELECTION SET 
 

11.1.1. SELECTION SET CREATION 
Create basic Selection set: 

 Command Find Elements Ctrl+F → In opened window, select the Previous Search option. → When the 

search results appear, click the Create Selection Set button. New selection set will appear in the Selection 

Sets palette. 

 Manually select elements directly in the 3D model viewport. →Click New Selection Set in the upper part 

of Selection Sets tab or click New Set button in Selection ribbon in the upper part of the interface. 

→Name selection set and set the destination folder. 

Create Smart Selection Set: 

 Click New Selection Set in the upper part of Selection Sets tab or click New Set button in Selection ribbon 

in the upper part of the interface. → The Create New Selection Set window will open. → Define the 

folder in which the selection set will be created and name it. → Click on the New Rule button to define 

rules. → Finish the procedure by clicking the OK button.  

11.1.2. CREATE SMART SELECTION SET - EXAMPLE 
As an example, we will create a selection set of walls that have the property Area less than or equal to eight 

square meters (8 m2). 

Select the Selection Sets palette. → Click on the New Selection Set icon. → The Create New Selection Set 

window opens. → Define the folder in which the selection will be saved and name it. → Click on the New 

Rule button and define the condition for including elements within this rule. → Inclusive → Select the criteria 
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of Buildings. → Click the New Rule button and define the Intersect state. → Select the following criteria, e.g. 

Category and then Walls. →Then a New Rule and we select the Intersect option. → Select the Element Query 

option. → Select Insert Query → Property Value →Select the Area parameter on the list. → Choose Property 

Type Numeric → Define the Less Equal condition. → In the field below, enter the number 8. → Finish the 

procedure by clicking the OK button. → Created Selection set will appear in the list of Selection set palette. 

If we want to show the elements which created selection set incudes, we have to select certain selection set 

in the Selection set palette list and selected elements will be highlighted. We can isolate selected elements 

with the Isolate command. With this procedure, we have created a Smart Selection set which includes 

elements that will fulfill defined rules even after updating the model. Smart selection set could be used for 

different analysis, quantity takeoffs and schedule animation. 

 

 

11.2. EDITING SELESTION SETS 
 

11.2.1. DISTRIBUTION OF SELECTION SETS IN FOLDERS 
Select the Selection Sets tab. → Click on the Manage Selection Sets button and select the desired selection 

set. → Mark the checkbox in front of the Allow Moving Selection Sets (through drag and drop) command and 

move the selection set to the desired folder. 

11.2.2. RENAME SELECTION SETS 
Select the Selection Sets tab.→ Click on the Manage Selection Sets button. → Choose the selection set you 

want to rename. → Click on the Edit button and rename it.  

11.2.3. COPY SELECTION SETS 
Select the Selection Sets tab. → Click on the Manage Selection Sets button. → Choose the selection set you 

want to copy. → RC → Click on the Copy command.  

11.2.4. DELETE SELECTION SETS 
 Select the Selection Sets tab. → Click on the Manage Selection Sets button. → Choose the selection set 

you want to delete. → Click on the command Delete command.  

 On the list in the Selection Sets palette, choose the selection you want to delete. → RC → Delete  
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12. CUSTOM BREAKDOWN PALETTE 
The Custom Breakdown tool is used when we want to classify the elements in the model based on certain 

criteria. Usually these criteria refer to the specific property of the selected elements. We can use the Custom 

Breakdown tool, for example, for the 3D BIM model quality control. This tool allows us to check if some 

element's attribute is written incorrectly. With this option the software detects all differences in the entry of 

properties, such as spaces, uppercase and lowercase, numbers, etc. In this way, we can quickly detect 

different deviations in order to improve the quality of the 3D BIM model. 

12.1. EXAMPLE OF CREATING A NEW CUSTOM BREAKDOWN  
Let's create a new Custom Breakdown structure. We will take category Spaces and we will break them down 

by floors and their names. 

Click on the arrow next to the New button. → Select the Blank Custom Breakdown option. → In the Name 

field, enter the name. → In the Type field, select Category option and then select Spaces category. → Click 

on the Use Selection button. → Click on the arrow next to the Add Breakdown Rule and choose the Group 

By Building Level rule. → Click again on this icon and select the Group By Discrete Property rule. This item 

represents non-numerical property. → The Select Discrete Property window opens, where you select 

property the Name. → Click OK. 

 

 

12.2. 3D COLOR CODED VIEW  
The 3D Color Coded View is located on the View toolbar. We can activate it with click on tab above the main 

viewport. It shows the Custom Breakdown in different colors. When we activate the Color Coded View, the 

model is gray because the color codding hasn't been applied yet. This tool paints each custom breakdown 

group with different color and the elements in the main viewport have the same color as corresponding 

group in custom breakdown tree.  
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12.2.1. ADDING COLOR CODING TO CUSTOM BREAKDOWNS 
Open the Custom Breakdown palette and choose the Custom Breakdown list. → Click on the Edit button. → 

The Edit Custom Breakdown window opens. → Click on the Reset Tree button to see the basic rules. → Select 

the desired rule which will have colored subgroups. → Select the Set Color Coding Rule command. → A 

colored square appears next to the name. This means that the Color Coding Rule command is activated, 

which also reflects on elements in main viewport which are colored with corresponding colors.   

12.2.2. SHOW ONLY COLORED ELEMENTS  
This is a tool that shows us only the colored elements in the 3D Color Coded View viewport. The command is 

located in the 3D Color Coded View toolbar. 

 

12.2.3. CHANGE COLOR OF 3D COLOR CODED ELEMENTS  
Select the Custom Breakdown palette. → Click on the Edit Legend button. → The Edit Color Legend window 

will open. → Select the items from the list and click on the Change button. → The color palette will open, 

where we can define a new color for certain item. 
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13.  CLASH DETECTION 

 

Clash Detection is a module that allows us to make clash analysis between the individual elements of the 

model. For example, we can detect clashes between structural elements and MEP systems or between 

elements of individual MEP systems. Clash detection is extremely important at all stages of the project and 

for the timely implementation of the project with no additional cost. The Clash Detection palette is located 

in the bottom of the screen. It contains Jobs where each Job represents a clash analysis between the 

individual model elements. The Job has specified list of all detected clashes between the elements of the 

groups we have selected for certain Job. 

 

13.1. RUN CLASH DETECTION 
 

Select the Clash Detection palette, tab in the bottom of the screen. → Click on the Run Clash Detection 

button. → Clash detection window opens. → Define the name of the clash in the Job Name field. → Select 

the group of elements on the left side of the window. → Select the group of elements on the right side of 

the window. → Determine the type of clash, e.g. Clash Type: Hard. → Define the Tolerance. → Click on the 

Run button. → When the analysis is completed, the Analysis Complete window appears with number of 

detected clashes. → Job Analysis is shown as a list in the palette window, with all clashes that the software 

has detected.→ To see clash detection report click on the Overview button (clash analysis).  

 

CLASH TYPE determines the type of clash between the individual elements in the process of analysis. 

 Clash type Hard detects clashes where the elements go through each other.  

 Clash type Hard Conservative checks if there are elements in each other. 

 Clash type Clearance detects if desired clearance between elements is satisfied. 

 Duplicate (Bounds) option is used for checking if there are duplicate elements in the 3D model.  

When we Run Clash Detection 

Left Clash Detection Groups 

(left window) and the Right 

Clash Detection Groups (right 

window) are used in analysis 

of mutual coalitions. The 

analysis can be done between 

individual groups, such as 

categories, created selection 

sets, worksets, etc. 
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Clash Detection palette contains an overview of all clashes within the certain analysis (Jobs). In the Jobs list 

we select the analysis we want to review. The report includes the ID, category of element as well as the level 

on which the collision is detected.  This information is shown for elements from both groups we used in 

analysis. 

13.2. CREATE VIEWPOINTS 
 

13.2.1. CREATE VIEWPOINTS 
Choose the desired collision from the list. → Click on the Clash View Mode button. → Select the last option 

from the drop-down menu on the right side of the screen: General Information, Linked Documents and 

Viewpoint. → Click on the Create button. 

 

13.2.2. SIMULTANEOUSLY CREATE 

MULTIPLE VIEWPOINTS 
Select the desired clash from the list. → 

Click on the Clash View Mode button. → In 

the drop-down menu on the right side of 

the screen, select the Viewpoint option. → 

Click the Update button and select the 

From Viewpoint option. → The Select 

Viewpoint window opens. → Select the 

desired view from the list and save it under 

that name. → The Update option allows us 

to change the previously made Viewpoint.  

Note: Viewpoint does not appear when we select multiple clashes. When we select one clash, the Viewpoint 

activates. The Clear command allows us to clear the Viewpoint. 

 

13.3. COMMON INFO  
 

General Information can be selected in 

the drop-down menu located in the 

upper right corner of the Clash 

Detection palette. It shows general 

information about clashes. Some 

parameters could be changed, such as 

the Name, the Status and the 

Comments. 

Other parameters, the Element 1 and 

Element 2, the Location and the 

Distance, are read only and cannot be 

changed. 

If we want to save changings we made, 

click the Save button.  
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13.4. JOINING INDIVIDUAL CLASHES INTO GROUPS  
 

In practice, it often happens that individual clashes are interconnected, because they are caused by the same 

problem, or can be resolved in the same way. These clashes can be combined into the group of clashes and 

that group can be treated as a major clash which has to be solved. 

Select desired clashes on the list. → RC → Click on the Group command. → The Clash Group window opens 

where we define the group name in the Group Name field.→ A newly-formed group appears in the clash list. 

A context menu appears with right click on the clash where we can define the status of an individual clash, 

remove it from the group, etc. 

 

13.5. ADDING DOCUMENTS TO CLASHES 
 

In the Clash Detection palette, in the top-right corner in the drop-down menu next to General Information 

and Viewpoint, there is a tool for linking documents that allows us to add documents to a particular clash. 

Documents that are added to clash can be in the form of a web page, JPG files such as photos from a site, 

PDF files such as project documentation, etc. 

Select the clash which we want to add the document. → Select the Linked Documents option. → Click the 

arrow next to the New button and select the Web Document option. → Copy the web page title.→ Fill up 

the desired fields, such as Name, Address and Keywords. → Finish the procedure by clicking the OK button.  

13.6. PREVIEW CLASHES IN LEVEL MAP 
 

In addition to individual clashes, we can activate the Level Map tool, which shows the position of clashes 

inside the building in plain view. Before activating the Level Map tool, make sure that the clash options are 

displayed within the Level Map tab in the Options menu. 

Select the Level Map tab. → Click on the Options button. → Select the Level Map Options option. → We can 

choose between parameters such as Show Clashes, Show Elements, Show Clashing Edges. → This determines 

the clash display. 
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13.7. CLASH EDITING  

 

13.7.1. SETTING A CLASH STATUS  
 Choose the desired clash. → RC → Click on the Change Status 

command. → Select one of the predefined statuses. 

 Click on the Options drop-down button in the top right corner of 

clash detection palette and select the Clash Statuses option. → The 

Clash Statuses window will open, where we can edit or delete 

existing status, or specify new ones. If we choose a certain status 

from the list, by clicking the Edit button, we can change the name 

and color of the status. By clicking on Add we can add new status. 

 

13.7.2. EDITING APPEARANCE OF CLASHED ELEMENTS 
Bexel Manager allows us to change the colors of the elements 

involved in a particular clash, as well as to set the display of elements 

not involved in a clash. 

 Click on the Options button. → Select the Clash Options. → In 

the Clash Detection tab, in the Clash View Options section select 

the Clash Elements option and check the checkbox Colorize. → When we click on the color rectangle 

that represents the color of the elements involved in the clash, a color palette opens. We choose the 

desired color to change the appearance of the elements involved in the clash.  

 

13.7.3. EDITING APPEARANCE OF OTHER ELEMENTS 
Parameters, such as Render Other Elements, Dimming Transparency, Dimming Render Type and Dimming 

Color allow us to change the appearance of other elements that do not participate in clash.  

 

Command Render Other Elements 

allows us to view other elements in 

several ways: 

 Normal → Elements that do not 

participate in clash are displayed 

commonly. 

 Hide → This command hides all 

elements that do not participate 

in a clash.   

 Dim → Other elements will 

display transparent. 

 Dimming Transparency → 

Determining the degree of 

transparency of other elements. 

 Dimming Render Type → This command is used in the same way as the Render Type in the context 

menu. 

 Dimming Color → Determining the color of the other elements.  
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13.8. CLASH DISTRIBUTION AND FILTRATION 
 

We can sort and filter individual clashes in clash groups based on the desired parameters. Clash filtering is 

done by right clicking on a specific column and selecting the desired condition on which the results will be 

filtered. 

Select the Floor column. → RC → Select the floor. → Click on the OK button. →Activated filters appear in the 

program with the star *. Clash filtering within a single clash analysis folder can be done based on several 

selected parameters. 

 

13.9. THE CLASH ANALYSIS REPORT 
 

At the end of the clash analysis, a report is made. We can export it as a PDF or HTML file. The report consists 

of three parts. The first part contains general information about the number and type of conflicts and their 

status. The second part is clash detection matrix. The third part is each clash separately, with a clash picture. 

The HTML file is opened using the desired browser. By double-clicking on the chosen clash image inside the 

HTML file, the photo is enlarged. 

 Select the desired number of clashes. Individual clashes are added using the Ctrl key. If you want to 

highlight all collisions, press Ctrl+A at the same time.  

 Select the Clash Report command. → The Export Clash Report window opens, where we set the image 

display properties in the Image Parameters field, the Level Map properties in the Show Level Map field, 

and the properties of other information in the Other Information field. → Click on the Export button and 

choose where and in which format the report will be saved. 
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13.10. BCF MANAGER REVIEW  
 

BCF Manager Review is a tool used to share and view models, it supports open XML file formats, and 

therefore work processes and communication between participants in the BIM work environment. In 

practice, it allows participants in the same project to exchange files in the form of BCF formats, regardless of 

the software used. For example, the user of BEXEL Manager reveals a possible mistake in the model and 

sends it to the user who use other software. The forwarded file in the BCF format is simply opened in another 

software tool. File sharing in the BCF format between different participants using different software tools is 

only possible if the model originates from the same original IFC model and the software tools of all 

participants support the open BCF format. 

Choose the Manage tab. → Select the BCF Manager Review tool. → Click on the New button.  

 

14. QUANTITY TAKEOFF PALETTE  
 

The Quantity Takeoff palette is an excellent platform for calculating the quantities of individual groups of 

elements directly from the geometry of the 3D model. The palette is located in the lower part of the screen 

and consists of two parts. On the left side, there is a list of previously created quantity takeoffs and on the 

right site there is an overview of the content of the individual quantity takeoff. The quantity takeoffs which 

were previously created could be edited or deleted. To make it easier for further use, we can create folders 

where we will store individual quantity takeoffs. 

 

14.1. CREATING A NEW QUANTITY TAKEOFF 
 

Click on the arrow next to the New button. → Select the Blank Quantity Takeoff option. → Set the name of 

the quantity takeoff in the Name field. In the Type field, choose the desired item, e.g. Categories and select 

the category Walls. → Click on the Use Selection button. → Define the first criteria for the quantity takeoff: 

Group by Family. → Select Quantities. → RC → Choose the Add Quantity command. → The Select Quantity 

window will open, where we can select a value, for example Area. → Confirm the selection by clicking the 

OK button. → In the same way, we can add other parameters if we want to obtain more quantities of used 

selection.  

 For some parameters, such as Area, we can change the unit of measurement and change quantity formula. 

In the Select Quantity window, in the Aggregate Function field, determine which function is going to be 

used: the sum, the average, etc. In the Unit field, we can click the Change button to select the desired 

units. 

 Discrete Property is used when we want to define the text from the element property as a rule (for 

example, workset). 

 Count is a parameter that gives us the number of individual elements inside the quantity takeoff.  

 

Note: When we select an item in the created quantity takeoff, the elements, which belong to it, become 

yellow colored in the main viewport. If this selection command is not activated, the elements will not be 

highlighted. In this case, do the following: Click the Selection button in the Quantity Takeoff palette. → Check 

the checkbox in front of the Auto-Select From Takeoff item.  
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14.2. DELETING AND EDITING THE QUANTITY TAKEOFF 
 

When we are not satisfied with the created quantity takeoff, we can delete it or edit it. We have the option 

to remove or add individual elements to the desired quantity takeoff. 

 Select the created quantity takeoff from the list. → RC → Select the Delete button. → We have deleted 

the entire quantity takeoff. 

 Quantity takeoff can be deleted by clicking the Delete command, located in the toolbar in the palette 

window.  

 Select the created quantity takeoff from the list. → RC → Select the Edit button. → The Edit Quantity 

Takeoff window will open. → Click the Reset Tree button. → Select the existing rule with the RC. → Select 

the Remove command to remove the rule. → OK → The change of the quantity takeoff is displayed 

immediately. In the Edit Quantity Takeoff command, we can also add new rules.  

 

Note: Selected quantity takeoff can be changed by clicking the Edit command, located in the toolbar in the 

Quantity Takeoff palette. 

 

14.3. QUANTITY TAKEOFF TEMPLATES 
 

The quantity takeoff classifications and breakdown structures can be very similar from project to project. It 

also depends on the type of object, location, construction technology, defined standards, etc. When you 

create a quantity takeoff that can be used for future projects, save it as a Template. 

14.3.1. SAVE THE QUANTITY TAKEOFF TEMPLATE 
Select the desired Quantity takeoff from the list. → Click on the Template button. → Save. 
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14.3.2. IMPORT THE QUANTITY TAKEOFF TEMPLATE 
Click on the arrow next to the New button. → Select the Blank Quantity Takeoff option. → In the Type field, 

select the option Families. → Then select the Walls family. → Click on the Use Selection button. → Then click 

on the QTO from Template button. 

 

14.4. QUANTITY TAKEOFF COLOR CODED RULE  

We can use the Color Coded Rule tool when we want to visually present elements in the main viewport as 

group of individual elements that certain quantity takeoff contains. 

14.4.1. COLOR CODED RULE 
Select the created Quantity takeoff. → Select the Edit icon. → Click on the Reset Tree button. →Select the 

rule on which we want to apply the Color Coded Rule on. → Choose the 3D Color Coded View display type in 

the toolbar of the main viewport. → Click the Viewer mode command located in the right corner above the 

main viewport and select the Quantity Takeoff option.   

14.4.2. COLOR CHANGE AND TURNING OFF THE COLOR CODED RULE COMMAND 
RC on the selected item within the created quantity takeoff. → Click on the Edit button. → Select the Choose 

Color icon. → Define the desired color. → Finish the procedure by clicking the OK button. → The change is 

immediately visible in the viewport. 

 

RC on the selected item within the created quantity takeoff. → Click on the Edit button. → Activate the Reset 

Tree command. → Click on the Color Coded Rule button to turn it off. 

 

14.5. QUANTITY TAKEOFF EXPORT 
 

The export of the 

quantity takeoff can be 

done in the form of an 

XSLX file format. The 

exported file consists of 

three sheets, where 

the same quantity 

takeoff is displayed in 

different ways. The first 

sheet, named as Flat_ 

Table, contains a 

simple table which 

represents the list of all 

elements that certain 

quantity takeoff contains. In the second sheet, named as Breakdown_Structure, the elements are divided 

into different groups. The last sheet, named as Breakdown_Structure_Elements, has actually similar structure 

as previous sheet which is divided on the level of each individual element. The quantity takeoff report could 

also be complemented with screenshots of related quantity takeoff items.  

 

Select the quantity takeoff you want to export. → Click on the Export button. → The Export Quantity Takeoff 

Report window will open. → Check the Styled Report option and define the appearance and content of the 

report and the storage location. → Export.  
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15. SCHEDULE EDITOR PALETTE 
 

The Schedule Editor palette is designed to manage existing and new schedules, create a 4D model and a 

schedule animation. We activate the palette by clicking the same-named tab on the bottom of the screen. 

The schedule consists of several activities on different levels. When the activity consists of several sub-

activities, in the BEXEL Manager software solution it is called the Parent Task. Its sub-activity is called Children 

Tasks. Activity at the lowest level, which does not contain sub-activity, is called Leaf Task. In BEXEL Manager, 

the schedule can be displayed in several different ways. There are display types Logic, Gantt and Line of 

Balance (LOB). They are activated by clicking on corresponding buttons located in the upper right corner of 

the Schedule Editor palette. 

 

15.1. DISPLAY TYPE LOGIC 

 

 

Schedule display type the Logic allows us to create new activities and their connections. Activities are 

represented by icons with images depend on the way they are made. This also applies to the activities 

relations. Activities inside the schedule are arranged at different levels. Switching between individual levels 

is done by double-clicking on the individual icon of the activity. In the upper left corner of the Logic, the path 

to the individual level with the currently selected activities is displayed. We can also use the Go Back 

command to switch to the previously selected level and the Go Up command, which allows us to see a higher 

level. The toolbar contains commands such as Zoom In, Zoom Out and Scale to Fit, which are used to increase 

or decrease or to optimally display the schedule. The Select Tasks command allows us to select all the 

activities at once, while Select Relations allows us to simultaneously select all relations. When we click on the 
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desired selected activity in the display type Logic, at the bottom of the screen, a menu is activated where we 

can define individual activity parameters, such as the Name and the Type of activity. By clicking on the desired 

relation, a menu is activated where we can edit the characteristics, such as the type of the relation in the 

Type field, start of the next activity in relation to the previous one in the Lag type field and the type of delay. 

Note: The duration of the activity can only be changed if the activity is selected at the lowest level, which is 

called Leaf Task. When we change the duration of the activity at the lowest level, in parallel, the duration of 

the activity at the higher-level changes, under which the activity was selected at the beginning. This applies 

to all scheduling activities, regardless of the display. 

15.2. DISPLAY TYPE GANTT 
 

 

The display type Gantt consists of a list of activities on the left and gantogram on the right side of the palette, 

which shows activities in the function of time and mutual relations. Leaf tasks or activity at the lowest level 

are shown in blue. Activities with sub-activities are colored in gray. It is possible to move activities within the 

gantogram, but not to change the duration, and all the changes made are automatically transferred to all 

sub-activities. We can also choose an arbitrary relationship and change its characteristics. When several 

schedules are listed, they can be compared with the Compare With command. This is a very useful feature 

when we want to make changes to the schedule and check how these changes will affect the entire course 

of project implementation. The toolbar contains commands such as Zoom In, Zoom Out, and Scale to Fit, 

which work the same way as in the Logic view. The Collapse All and Expand All commands allow us to collapse 

or expand the activity list. The Filter command allows us to search activities based on the activity name or 

other selected parameters. 
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15.3. DISPLAY TYPE LINE OF BALANCE (LOB) 

 

The display type Line of Balance illustrates the progress of the activity according to its spatial and temporal 

distribution. Unlike the display type Gantt, we cannot present critical paths here. Activities are displayed in 

rows whose color depends on the task. Dashed line tells us that several different tasks are perform 

simultaneously in the object. In the left corner of the Line of Balance display type in the Show Up To field, we 

can determine the level at which the activity is displayed. Using the Show Tasks Name command, we can 

determine whether the activity names are visible or not. The Filter command works the same way as in the 

Gantt view. When we choose the desired activity, this activity is illustrated in red. When we click on the 

bottom endpoint, we can move the activity over a given period of time. Clicking on the top end will change 

the duration of the selected activity. The Pop Out command gives us a display of the whole screen of the 

schedule and refers to Logic, Gantt and Line of Balance. 

 

15.4. BASIC OPERATIONS OF A SCHEDULE  
 

Within the Schedule Editor palette, in the upper left corner of the list there are basic commands for changing 

the schedule. The Export and Import commands will be discussed later in this chapter. 
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15.4.1. CREATING A NEW SCHEDULE  
New Schedule → The New Schedule window will open. → In the Name field, give the name of the new 

schedule. In the Description field, we can enter the description of the schedule, but this is optional. → Finish 

the procedure by clicking on the OK button.  

Note: We create a new schedule when we want to import an already created schedule from another software 

or create it in the BEXEL Manager. 

 15.4.2. RENAMING THE SCHEDULE 
Edit → The Edit Schedule window will open. → In the Name filed, give the new name of the schedule.  

15.4.3. DELETING THE SCHEDULE 
By clicking the Delete button, we delete the entire schedule. This command is irreversible, to what the 

program itself warns us. 

15.4.4. COPYING THE SCHEDULE  
Select the schedule. → Duplicate → The New Schedule window will open, where we define the name and 

description of the schedule. → Finish the procedure by clicking on the OK button.  

Note: This function is used when we want to make changes to the existing schedule and we want to check 

how the changes will affect the flow of the entire schedule. Using the Compare with command in the Gantt 

display type, we can compare the selected schedules.  

 

15.5. SCHEDULE SETTINGS 
The Settings command is located in the upper right corner of the Schedule Editor and is displayed with a gear 

icon that is visible in all schedule display types. The Settings window allows us to change the settings of the 

whole schedule, which are entered from another program or created in the BEXEL Manager program. It 

consists of three tabs: TIME, ANIMATION and COLORS. 

TIME TAB 
Here we can define different 

parameters related to the time flow 

of the schedule. We can determine 

which will be the first working day of 

the week or the First Day of the 

Week. In the Project Start Date and 

Project Finish Date windows, we 

determine the start and end of the 

project. Default Task Duration 

provides the ability to determine the 

automatic duration of the activity. 

The Scale Schedule option 

determines the duration of the work schedule for a given coefficient. Working Hour Lag Calendar determines 

which calendar will be treated to delay the activity if two different tasks belong to two different calendars. 

Task Constraint Priority tells us which constraints are a priority in calculating the duration of a particular 

activity. 

Note: Under the Settings command in the Time tab, under the Project Start Date and Project Finish Date we 

determine the first and the last day of the project. In the currently created schedule, the duration is 

determined by the activities within the schedule. When the duration of the activity exceeds the last day of 

the project specified in the settings, the program warns us. 
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ANIMATION TAB 
On the Animation tab, we can set the display order of all the model elements in the 4D-animation of the 

schedule. This setting is applied to all forward activities of the schedule. 

COLORS TAB 
On the Colors tab, we can determine whether the building elements will be colored during the mapping 

process based on the methodology or link rules. Link Rules are the rules by which we connect building 

elements with the activities of the schedule. The selected colors can be changed using the Change Color 

command. The Randomize Colors command allows us to simultaneously change all the selected colors, 

including those that we have previously defined. 

 

15.6. SCHEDULE CALENDARS 
 

In BEXEL Manager, we can create new and edit existing schedule calendars. Calendars are activated by 

clicking on the Calendars button. The Calendar Editor window consists of the Working Hours and Exceptions 

tabs. 

15.6.1. CREATING THE CALENDAR 
Calendars → The Calendar Editor window will open. → Click on the New button. → Name the calendar. → 

Finish the procedure by clicking the OK button. After execution, we determine working and non-working 

days, working hours and all exceptions, such as holidays. 

15.6.2. SETTING THE WORKBOOK 
We define the workbook by selecting the working time by clicking on the clock. We can use the Ctrl key to 

add hours. Shift key is used to select everything between the two selected items. If we want to define non-

working days, check the checkbox in from of the Non Working.  

 

15.6.3. RENAMING THE CALENDAR 
Calendars → Select the desired calendar. → Click on the Rename button. → The Edit Calendar window will 

open, where we define the new name of the calendar. → Finish the procedure by clicking the OK button.  

15.6.4. DELETING THE CALENDAR 
Calendars → Select the desired calendar. → Click on the Delete button. → This command is irreversible.  
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15.6.5. COPYING THE CALENDAR 
Calendars → Select the desired calendar. → Click on the Duplicate button. → The New Calendar window will 

open, where we define the name of the calendar, which is also a copy of the selected calendar.  

15.6.6. DEFAULT CALENDAR 
When we want a calendar to be the basis for the next schedules, we click on the Set As Default button. The 

default calendar next to its name has the information Default.  

15.6.7. IMPORITNG THE CALENDAR 
Calendar → Select the desired calendar. → Click on the Import button. → The Calendar Import window will 

open, where we determine which schedule we will import into the calendar.  

15.6.8. DETERMING THE CALENDAR EXCEPTIONS 
Exceptions → Click on the New button. → The Calendars Exception Editor window will open. → In the Name 

field, enter the exception name, e.g. Labor Day. → In the Range field, determine the period for which the 

exception will be applied. In the Recurrence field, determine the repetition interval for the selected time 

period. → Finish the procedure by clicking the OK button.  

All the feature features can be changed later by clicking the Edit button or deleted by clicking the Delete 

button.  

 

15.7. CREATING A NEW SCHEDULE ACTIVITY 
 

In order to show the creation of a new activity, we will first activate the Gantt display. When we want to 

create a new activity, we first describe the activity or schedule within which a new activity will be created. 

We can form contents of various activities. In this section, we will present the creation of Blank, Milestone 

and Linked activities. 

15.7.1. CREATING THE BLANK ACTIVITY 
Blank Task or empty activity is the activity that is not linked to a building block of the object, but can be added 

later. 

First, we can make a new schedule. → Then click on it to determine where we will place a new activity. → 

Click on the arrow next to the New Task button. → Select the Blank item. → The New Task window will open, 

where in the Name field, we assign the name of a new activity. → Finish the procedure by clicking the OK 

button. → Activity will appear in the schedule.  

 

15.7.2. CREATING THE MILESTONE ACTIVITY 
Milestone activity illustrates the completion of a certain phase. As such, there is no time duration and 

therefore does not appear in the animation of the schedule. It also cannot have sub-activity and cannot be 

connected to building blocks. The gantogram is shown in the form of rhombus. 
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Select an activity in which we will install a new activity. → Click on the arrow next to the New Task button. 

→ Select the Milestone item. → The New Task window will open, where in the Name field we assign the 

name of the new activity. → Finish the procedure by clicking the OK button. → Activity will appear in the 

schedule. 

15.7.3. CREATING THE LINKED ACTIVITY 
Linked Task is an activity with which we associate different elements. It can be associated with individual 

elements, such as individual floors of a particular building, families, individual building blocks, Selection Sets, 

etc. 

Select an activity in which we will install a new activity → Click on the arrow next to the New Task button. → 

Select the Linked item. → The Reference Objects window will open where we first select which items, we will 

associate with the activities we are creating. → In the drop-down menu, choose, for example Selection Set 

and select the desired Selection Set. → Finish the procedure by clicking the OK button. → Newly created 

activity will appear in the schedule, which gets its name by the chosen Selection Set.  

Note: When creating the Linked activity, we can simultaneously link several elements, for example, more 

floors. We can also add more building blocks from the model to more activities at the same time. The 

procedure is the same as adding one element to one activity. 

 

Note: The image shows the process of creating a Linked Activity, where we added the desired Selection Set 

to it when creating it. It is proposed to set up Smart Selection Sets, which will be automatically updated every 

time the model is updated and include new building blocks that meet the selection requirements. 

15.8. CREATING LINKS BETWEEN SCHEDULE ACTIVITIES 
In BEXEL Manager, we can create links between the lowest-level activities as well as between individual 

groups of activities. Before making connections, we suggest activating the Logic view, because this view is 

the most transparent. We can create interconnections in different ways. 

15.8.1. CREATING LINKS IN LOGIC DISPLAY TYPE 
We associate the desired selected activity by the link with the desired selected activity that follows. In this 

way, we have created a link between these two activities. A link editor is displayed at the bottom of the 

screen that activates when a link is highlighted. Here, we determine the type and delay of connections in 
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percentages or hours. At the same time, we can select multiple connections and at the same time change 

their parameters. 

15.8.2. CREATING LINKS IN GANTT DISPLAY TYPE 
Select the desired activity. → New Relation → Click on the Predecessor button and define the previously 

selected activities. → Determine the connection type and eventual delay. → Finish the procedure by clicking 

the OK button. → In the same way, we select the activity that follows the previously selected activity, by 

selecting the Successor option.  

Note: The advantage of forming a link in the Gantt display type is that we can create links between activities 

at different levels, while we cannot do that in the Logic display type. When it comes to the same links or 

relationships between individual activities, we can simultaneously create several links. The procedure is the 

same as creating one link. 

 

Note: The figure shows the relationship between the two desired items selected. In this example, we have 

activated Superstructure defined by previous activities, in this case Substructure. In the same way, we 

determine the activity that begins when the Superstructure activity is completed. In this example, in the New 

Relation window, highlight the Successor item. Interconnection between different activities can be defined 

in the Task Editor window on the Relations tab.  

 

15.8.3. DELETING LINK 
Select the desired link. → Delete.  
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15.8.4. COPYING LINK 
Activate the Logic display type. → Select Relations → Copy → The Paste window will open, where we select 

the phase in which we will copy the selected connections. 

 

15.9. TASK EDITOR 
 

Task Editor is activated when we select a specific activity. It contains several tabs such as Time, Relations, 

Rules, Documents and Settings. Task Editor allows us to change the characteristics of each selected activity, 

while using the Settings command, we edit the entire schedule. Cost, Quantities and Resources tabs refer to 

the creation of a 5D model. On the toolbar, in the Name field, we can change the name of the activity. When 

we do not want the activity to be named based on the Link Rule based on which it was created, we leave the 

Automatic field blank. In the Task Type field, we can specify the type of activity, but this is only possible if the 

activity at the lowest level is selected, which has no sub-activity. 

15.9.1. TIME TAB 
When we select Leaf Task, or activity at the lowest level, which has no sub-activity, we can change the 

duration of the activity in the Duration field. In other cases, we cannot do that. 

15.9.2. RELATIONS TAB 
Allows creating links between individual activities. 

New → Predecessor or Successor → The New Task Relation window will open, where we mark the previous 

activity or activity that follows. → Finish the procedure by clicking the OK button.  

15.9.3. RULES TAB 
In the Rules tab, we can define the connection rules according to which the construction blocks of the model 

are associated with the items in the schedule.  

Rules → New → Link Rule → Select an item that we will associate with activity. → Finish the procedure by 

clicking the OK button.  

15.9.4. PROPERTIES TAB 
The Properties tab lists the activity features that are defined in the source program in which the schedule 

was created. 

15.9.5. DOCUMENTS TAB 
In the Documents tab, we can review which documents are attached to the building blocks of the selected 

activity, and we can also add new documents. The tab works the same way as the Documents palette, which 

is already displayed on page 32.  

15.9.6. SETTINGS TAB 
This card includes settings for displaying building blocks during the schedule animation. It contains similar 

functions as the Animation tab under the Settings command, with the exception that in this tab we only 

define the display of building blocks during animation, which relate exclusively to the selected activity.   

 

15.10.  SCHEDULE IMPORT AND EXPORT  
 

BEXEL Manager has option to import and export the schedule. We can import and export schedule from 

Microsoft Project and Oracle Primavera in XML format.  
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15.10.1. SCHEDULE IMPORT 
New Schedule → Name a new schedule. →Click OK.→ Click on the Import button and select the program 

from which we will import the schedule, e.g. Import from MS Project. → Select the file and click the Open 

button. → The Schedule import window will open. → Click on the Next button. → Select desired tasks to 

import → Finish the procedure by clicking the OK button.  

15.10.2. SCHEDULE EXPORT  
Export → Select the program in which 

we want to export the schedule and 

click, e.g. Export to MS Project. → The 

MS Project Export Settings window 

will open and we determine the 

extent to which we will export the 

schedule. → We can export mutual 

relationships by checking the 

checkbox next to Include Relations. → 

We can also decide whether we will 

export resources from the original 

schedule by checking the checkbox 

next to Include Resources. → By 

clicking the Export button, the Save As 

window will open, where we set the 

location of the output file → Finish the 

process by clicking the Save button.  

 

 

 

15.11. LINKING THE MODEL TO 

THE SCHEDULE 
In previous chapters, we explained 

how to create a new schedule and 

different types of activities. This was 

followed by an explanation of the import of a schedule from various software tools. Now we will explain how 

to connect individual schedule activities with BIM model. Regardless of whether we created a new schedule 

in BEXEL Manager or we imported it, the process of interconnecting the model with the schedule is the same. 

The main product of connecting the building blocks of the model to the individual schedule activities is the 

4D-model and 4D-simulation of the schedule. Based on the activities given in the schedule, first we make the 

appropriate selection. We have explained the procedure for creating individual selections in Chapter 11. Here 

we should mention two things. When we have a schedule, where similar activities occur, related to the 

implementation of similar project segments, we can form a smart selection set, which will combine building 

blocks that are associated with the above-mentioned similar activities. Activities at higher levels act as a filter 

that provides the program with relevant information on which building blocks from the selected selection set 

will be associated with certain lower level plan activities. In practice, this means that there is no need to 

create a special selection set for each activity at the lowest level that fits only this activity, but we can make 

a selection set that can be associated with numerous similar activities at the lowest level. This saves time, as 

the number of selection sets that are needed to connect the schedule with the model is reduced. The ultimate 

product of this is the BIM 4D-model with the 4D simulation. 
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15.11.1. LINKING THE INDIVIDUAL SCHEDULE ACTIVITIES WITH THE MODEL 
To perform this process, we activate the Gantt view. → Click on Rules button and the Task Rules Editor will 

open. → Select the activity with which we want to associate the elements. → Click Link Rule → In the drop-

down menu, select the Add command and then click Include. → The Reference Objects window will open→ 

Select Selection Sets from the Type: drop down list → Select selection sets that you want to link with task. 

→Finish the procedure by clicking the OK button. 

 

Note: In the same way, we can link the floors, categories, families, individual building blocks of the BIM 

model, etc. with the activities of the schedule. It is of the most importance that after every change in the 

schedule we update it. To do this, click on the Update command. Only after updating the schedule, Bexel 

Manager will display the elements in the animation, that we have just linked to the activities. 

15.11.2. LINKING MORE ACTIVITIES WITH MODEL ELEMENTES 
Using the Map command in the Link Rule window, we can link several different activities at once with model 

elements, and these can be floors, categories, families, etc. Most commonly, these are the smart selection 

sets that are created based on these activities in the schedule. 

To perform this process, we activate the Gantt view. → Click on Rules button and the Task Rules Editor will 

open. → Select the activity with which we want to associate the elements. → Click Link Rule → In the drop-

down menu, select the Map command, and then Include. → The Reference Objects window will open where 

we select already created Selection Sets. → Finish the procedure by clicking the OK button.  
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Warning: This command is active when the names of the chosen selection sets are exactly the same as the 

activity names. When we name the selection set, we need to pay attention to capital letters as well as to 

spaces, otherwise we cannot associate each individual activity with a certain Selection Set.  

 

15.12. LINK CONTROL BETWEEN SCHEDULE AND BUILDING BLOCKS OF THE MODEL 
 

15.12.1. DISPLAY OF BUILDING BLOCKS LINKED WITH ACTIVITIES IN VIEWPORT 
When we want to display building blocks in the main viewport, which are associated with a particular 

schedule items, we do the following steps. 

Activate the Gantt display type. → Select the schedule activity. → Click the Selection command and select 

the Select elements command. → In the viewport, the elements associated with this activity will be colored 

in yellow. 

Note: When creating the schedule animation, this way we check whether we have linked all the elements 

with a certain activity. 

15.12.2. DISPLAY ACTIVITIES LINKED WITH SELECTED ELEMENTS 
Activate the Gantt display style. → Select the desired items in the viewport. → Click on the Selection 

command and select the Find Tasks with Elements command. → In the schedule, the relevant activities are 

colored in blue. → When we want to display only those elements, click on the arrow next to the Filter icon 

and select the Filter Selected option.  
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15.13. UPDATING THE SCHEDULE 
 

Updating the schedule is done every time we make changes in the schedule. This implies changes related to 

selection sets, linking building blocks with schedule activities, deleting interconnections, etc. Updating is not 

required when changing parameters related to the time period of the activity. 

Schedule Editor → Update → The Schedule Update window will open, where on the left side appears 

information of the items that will be updated. 

Note: The Distribution warning provides information about the number of items that will not be associated 

with any activity. The Link Rule warning gives us the number of elements from the models that were not 

previously associated with the schedule items but will be linked after the update. Icon Warnings lets us view 

all warnings. 

 

16. SCHEDULE ANIMATION  
 

4D model and the schedule animation represents the ultimate product of connecting elements of the 3D 

model with the schedule. When we have several schedules in the model, we first need to select the desired 

schedule in the Schedule Editor tab that we want to display in the animation. Also, before creating an 

animation, it is necessary to update the schedule within the Schedule Editor when entering the changes. The 

animation is visible only in the Schedule Viewer view. On the Schedule Animation tab, there are additional 

options for editing an animation of the schedule. 

 

16.1. SCHEDULE ANIMATION PALETTE 
 

The Schedule Animation palette is activated by clicking the tab at the bottom of the screen. It consists of 

several parts. In the lower part, there is a timeline with standard commands, which we already learned on 

the Scenes and Animations tab. To preview schedule animation, we use Schedule viewer located above the 

main viewport window. It will also show the activity list and the total progress and cost. In the right-hand 

corner of the Schedule Animation palette, we can choose the week we want to display in the animation. In 

the Schedule Animation tab, we can choose to display task or animations. The process of creating animation 

is the same as the creating of standard animation. Animations can also be created in tab Scenes and 

Animations as explained earlier and then used in Schedule.  If we choose to display tasks, we will see the real 

time display of tasks that are currently in progress during schedule animation. 
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16.2. SETTING UP THE SCHEDULE ANIMATION  
 

4D animation settings are 

activated by clicking the 

Options button in the top 

right corner. Here we can 

set the length of animation 

and the number of frames 

per second, the interval in 

which the construction is 

updated and whether the 

project costs and the 

percentage of performed 

activities will be visible 

during animation. We can 

also choose how active, 

completed, and unfinished 

elements are displayed. If 

we want, we can set the 

exact time in which the animation will take place.  

Note: The animation update interval can be set at hourly, daily, weekly, or monthly rate. The shortest interval 

gives a better schedule animation. This means that if we define an interval at hourly rate, in the animation 

will be presented the construction of almost every element. When we define a daily interval, in the animation 

will be shown the construction of groups of building elements that were completed that day. For a quick 

overview of animations, the interval is set at a daily or weekly rate. For the final animations, we usually define 

an interval at hourly rate. 

 

16.2.1 USE STANDARD ANIMATION IN SCHEDULE ANIMATION  
In Chapter 9, we introduced the creation of a classic 3D model animation. It should be noted here that the 

animation we create in the Scenes and Animations palette can be exported and used for animation of the 

schedule. In such an animation, the camera changes according to the settings that are set in the standard 

animation, which is the main difference between classic simulation of the schedule and simulations based on 

pre-created animation. 

Activate the Scenes and Animations tab. → Next, according to the instructions in Chapter 9, create the 

desired animation. → when the animation is complete, first highlight it in the list, and then right-click the 

window. → In the newly opened subgroup, select Convert to Schedule and then Schedule Animation. → The 

Convert to Schedule Animation window will open, where in the Name field we define the name of the 

schedule animation. → We then activate the Schedule Animation tab. → Click on the Set Active button first. 

→ Then, in the Display window, select the Animation option and on the list, we select the animation we just 

exported. → We activate the Schedule Viewer in the main viewport and let the simulation of the schedule. 
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17. AUTOMATIC CREATION OF SCHEDULE BY ZONES AND METHODOLOGIES 
 

BEXEL Manager provides a 4D / 5D-integrated approach with the help of a quick creation of a basic schedule 

with automatic linking activities with different model structures and positions based on the classifications. 

This avoids the creation of the same activities and relationships, and possible mistakes. In this process we 

can add cost data and create a 5D model and the appropriate simulation. All this is possible on the Schedule 

tab, where we can create zones, methodologies and templates. Zones represent Zone Items that can be made 

from Selection sets, families, building blocks or floors. We form a schedule so that the zones coincide with 

the levels of the schedule. The highest-level zone is a parent task or activity at the highest level. The next 

zone represents a lower level of activity, etc. all the way to the production zone, which consists of a zone of 

objects that are in correlation with the activities at the lowest level. After creating a schedule, it is possible 

to regulate the project zones and the interconnections that represent the activities. This methodology is 

based on the structure of works and the positions of the selected classification for a particular type of object. 

When we have created the appropriate zones and methodology, using the Creation Template function, we 

can create a form for automatically creating the plan, which combines all the above items. This form, as well 

as created zones and methodologies, can be exported to other projects using the Exchange command. 

 

17.1. ZONE AND ZONE ELEMENTS  
 

To create individual zones, first we activate the Schedule tab in the toolbar at the top of the screen. Each 

zone consists of zoned objects whose type is determined during production. This means that we can create 

an empty zoned object that is not linked to model structures, but can be linked later. We can create zoned 

objects, already linked to the construction of individual model structures, such as buildings, categories, 

families, section sets, etc. Speaking about the zone we are talking about the level of activity, and when talking 

about zoned objects, we are talking about individual activities in the final timetable. The advantage of such 

a schedule is that at the same time we can form several zones, which represent the activities and levels in 

the final schedule. 

17.1.1. ZONE EDITOR 
We activate the Zone Editor by first clicking on the Schedule tab. The Zone Editor window is similar to the 

window for creating the schedule plan activity in the Logic display type. To the left are the zoned objects and 

their interactions or relationships. On the right side of the window, there is a list of zones. Formed zones and 

zone elements can be edited, modified, copied and added to different model structures, as well as 

interconnected in different ways. 

17.1.2. CREATING A NEW ZONE BY EMPTY ZONE ELEMENTS  
Schedule → Zone Editor → The Zone Editor window will open. → Click on the New Zone button. → A new 

window opens where in the Name field we define the name of the new zone and click the OK button. → The 

new zone is automatically activated. → Click the arrow next to the New Item icon and select the Blank or 

Linked option. → When we select the Blank option, the New Zone Item, window will open, where we define 

the name of the new zone in the Name field. → New zone is displayed in the Zone Editor window on the left. 

Note: The empty zone of the building can later be added to the elements from the model. Then click on the 

Reference Objects button, and in this way, in the same window that we just opened, select the type of 

element that we want to add to the object's zone. If we want to delete the elements that we just added to 

the zone, click the Clear command.   
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17.1.3. CREATING A NEW 

ZONE BY LINKED ZONE 

ELEMENTS 
Schedule → Zone Editor → The 

Zone Editor window will open. → 

Click on the New Zone button. → 

The new window opens where in 

the Name field we define the 

name of a new zone and click the 

OK button. → The new zone is 

automatically activated. → Click 

on the arrow next to the New 

Item icon and select the Blank or 

Linked option. → If we select the 

Linked option, the Reference 

Objects window will open. → In 

the Type field from the drop-

down menu, select which 

elements will be added to the 

zone, e.g. Selection Set. → After 

selecting the desired Selection 

Set-a, click on the OK button. → 

In the left part of the Zone Editor 

window, a newly formed zone 

element is displayed, which is 

named after the Selection Set 

that we added to the zone 

element. 

 

  

 

Note: We can check Automatic checkbox after selecting individual zone and that will automatically link zones 

to reference objects if they have the same name. For example, zone will be linked to selection set if both 

zone and selection set have the same name. 

17.1.4. LINKING ZONE ELEMENTS  
The individual zones are connected in the same way as the scheduling activities in the Logic display type. We 

link two desired zone elements with lines. When we mark the interconnection, the information on this link 

is activated to the right, and are identical to those in the Logic view. In the Type field, we can set the type of 

the selected connection, and in the Lag Type field, we set whether the delay will be displayed in hours or 

percentages. 

Warning: The Zone Editor field lists two types of Delete command. The Delete command, located on the 

toolbar, where the name of the zone is, allows us to delete the entire zone. On the other side, the Delete 

command, located in the right corner of the Zone Editor window, allows us to delete links or zone elements. 

Both commands are irreversible. 
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17.2. METHODOLOGY 
   

The Methodology Editor on the Schedule tab allows us to create a methodology based on the structure of 

works and the positions of selected classifications, such as, for example, Masterform or Uniform. The 

methodology can be used to create a new template or it can be exported using the Exchange command and 

can be used for other projects.  

17.2.1. CREATING THE NEW METHODOLOGY  
Schedule → Methodology Editor → New Methodology → The New Methodology window will open, where 

in the Name field, we define the name of the methodology to be created. → In the Classification field, choose 

whether to use Masterformat or Uniformat. → Finish the procedure by clicking the OK button. → We finish 

the procedure by clicking the OK button. → The just-formed methodology is immediately displayed in the 

left part of the Methodology Editor window. 

Note: The selected classification system can be formed as Uniformat or Masterformat. Alternatively, we can 

establish our classification system, which will serve as a basis for further work and enable the integration of 

methodology elements with items from the list of works from the 5D model.  

17.2.2. ADDING ELEMENTS TO METHODOLOGY  
Schedule → Methodology Editor → By using the New Methodology we create a new methodology or choose 

a pre-formed one. → Click on the New Item command. → The New Methodology Item window opens and in 

the Name field we define the name of the element. → We finish the procedure by clicking the OK button. → 

Select the newly created Methodology Item and click on the Edit button in the right part of the screen. → 

The Methodology Item Cost Items window opens where we select the appropriate item within the selected 

classification system. → Finish the procedure by clicking the OK button.  

 17.2.3. EDITING THE METHODOLOTY ELEMENTS 
Each element of the methodology is colored in its own color. This color is displayed during the schedule 

animation when the activity to which the element relates is taking place. The color can be changed by clicking 

on the square with the color. This opens the color legend, where we choose the desired color. To close the 

process, click the OK button. We can also change the object name by clicking the Change button. If we want 

to add another item from the classification system to the selected element, click on the Edit button and select 

or add the desired items. 

Warning: As with zone elements, there are also two types of Delete commands here. The Delete command 

on the toolbar will completely delete the entire methodology. The command at the right of the Methodology 

Editor window only deletes the selected item or link. Both commands are irreversible. 

 

17.3.  CREATION TEMPLATE  
Creation Template is a tool on the Schedule tab, which allows us to create a schedule. Here we can add 

individual zones as well as the methodology of works and set the desired order. By using the Exchange 

command, it can be exported and used in another similar project. 

17.3.1. CREATING THE TEMPLATE  
Schedule → Creation Template → The Creation Template Editor window will open → In the Name field, we 

define the name of the template. → Click on the arrow next to the New command and select Reference 

Children Based option. → Then activate the Reference Objects window, which we have already learned in 

creating of schedule and zone activities → In the Type window, select the Zone Items and select the desired 

zone. →  the same way, add the following zone or any other model structure, e.g. methodology of work. →  



 

66 
 

The order of adding zones should correspond to the levels of the schedule structure. → Finish the procedure 

by clicking OK. 

 

Note: When creating a 

template and its items, 

there is a Reference Based 

option. This means that 

the item directly connects 

the selected structures 

from the model to the 

activities. The Reference 

Children Based option 

allows us to link elements 

of one level of the model 

structure with lower-level 

elements. 

 

17.3.2. CREATING THE 

SCHEDULE BASED ON 

TEMPLATE  
Schedule Editor → New 

Schedule → The New Schedule window will open, where in the Name field we define the name. → In the 

Cost Version field, we define a classification system, but we can leave it blank. → A newly created schedule 

is automatically opened. → Click on one item 

of the schedule, whose frame is light green. 

→ Click on the arrow next to the New Task 

command and select the Creation Wizard 

option. → The same-named window will 

open. → Click on the arrow next to the 

Template command and select the Load 

option. → The Select Creation Template, 

window will open, where we select the 

desired template and then click the OK 

button. → Finish the procedure by clicking 

the OK button. → On the Schedule Editor tab, 

the newly created schedule is displayed 

based on template.  

 Note: Activities at the lowest level of the 

created schedule have a predetermined 

duration of 40 hours. The duration of the 

activity at a higher level is the sum of each 

sub-activity. We can elaborate time frame, 

change the duration of individual activities 

and create a completely realistic dynamic of 

work. 

 



 

67 
 

18. COST EDITOR  
 

The 4D BIM model is created when we add a schedule to the 3D BIM model. When we add the prices of each 

element to the model in addition to the time data, we create a 5D model and a basic 5D simulation. For these 

purposes, we use the Cost Editor module. Cost Editor tab is located at the bottom of the screen and it consists 

of three tabs: Classification Editor, Resource Editor and Cost Item Definition Editor. When we want to add 

cost information to the element of the BIM model, in Cost Editor we first create a classification system or use 

existing classification systems based on UniFormat and MasterFormat for example. When we create a unique 

classification system, we usually form it based on a list of works. All classification systems consist of a 

Classification Item, representing map structures, and Cost Item, which represent cost elements. Then we 

associate them with individual elements of the BIM model and usually combine data on the name of the 

elements, the description from the list of works, unit and price. 

 

18.1. CLASSIFICATION 
 

When we want to create or import a new classification system, we must first create it in the program. Created 

classification systems can later be renamed, deleted or exported in XLSX format. The exported files are then 

imported in Excel and can be re-imported in Cost Manager. We can have any number of classification systems 

in the program. 

 

18.1.1. CREATING THE CLASSIFICATION SYSTEM 
New Classification → The New Classification window will open. → In the Description window, we enter the 

name of the new classification system. → We finish the procedure by clicking the OK button. → The 

established classification system is displayed on the screen. 

18.1.2. RENAMING THE CLASSIFICATION SYSTEM 
Select the classification system. → Rename → The Rename Classification window will open, where we enter 

a new name in the Description window. → Finish the procedure by clicking the OK button.  

 

18.1.3. DELETING THE CLASSIFICATION SYSTEM 
Select the classification system. → Delete → A warning will be displayed asking if we are sure that we want 

to delete the classification system. → Finish the procedure by clicking the OK button. 

Warning: The Delete command is irreversible. This means that once we delete the selected classification 

class, we cannot restore it. 
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18.1.4. EXPORTING THE CLASSIFICATION SYSTEM 
When we finish creating a classification system, we can export it in the form of XLSX file. The exported table 

can be opened in Excel and modified as needed. After the changes were made, we can import back the table 

into the Cost Editor via the Import command. 

Select the classification system. → Export → Select the location where the file will be saved. → Finish the 

procedure by pressing the Export button.  

18.1.5. IMPORTING THE CLASSIFICATION SYSTEM 
First, we create a new classification system (point 18.1.1.). → Import → A window will open where we select 

the file that we want to import. → Finish the procedure by clicking the Import button.  

Note: When we import an Excel document to create a new classification system, the table is imported into 

the currently active classification system. This procedure is irreversible! 

 

18.2. CLASSIFICATION ITEM 
 

First, we name the folder structure in which the structure tab or classification item is currently located.  

Within the created folder structure, we can set up new folder structures and Cost Items. After creating, 

classification Item can be modified, copied or deleted. 

18.2.1. CREATING THE CLASSIFICATION ITEM  
Select the desired folder structure. → By right-clicking, activate a window and select New Classification Item. 

→ The Classification Item Editor window will open, where in the Code field we enter the name of the folder 

structure. → In the Description window, we can enter a description, but it is optional. → In the Query field, 

we can enter data, but it is not required. → Finish the procedure by clicking the OK button.  

 

Note: The Query contains the formula by which the desired elements of the BIM model in the Bexel Manager 

are automatically connect to the formed Cost Items from Cost Editor. This process will be presented below. 
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18.2.2. EDITING THE CLASSIFICATION ITEM 
Select the Classification Item, which we want to change. → By right-clicking, activate a window where you 

select Edit Classification Item. → The Classification Item Editor window will open, where we enter the desired 

changes. → If we want to change the Query item, click on the Change button. → The Element Query Editor 

window will open, where we change the desired data. → Finish the procedure by clicking the OK button.  

18.2.3. COPYING THE CLASSIFICATION ITEM 
Select the Classification Item, which we want to copy. → By right-clicking, activate a window where you select 

Copy. → Select a place where we will copy the map structure. → By right clicking on the selected place, a 

window will be opened where we choose the Paste option.  

18.2.4 CUTTING THE CLASSIFICATION ITEM 
Select the Classification Item, which we want to cut. → By right-clicking, activate a window where you select 

Cut. → Select a place where we will cut the map structure. By right clicking on the selected place, a window 

will be opened where we choose the Paste option.  

18.2.5. DELETING THE CLASSIFICATION ITEM 
Select the Classification Item, which we want to delete. By right-clicking, activate a window where you select 

Delete. → A notification will pop up asking if we really want to delete this item. → Finish the procedure by 

clicking the OK button.  

 

18.3. COST ITEM 
  

Cost Item contains information about unit price of the task, the way it will be connected with model elements 

(Element Query) and the way the quantities will be extracted from BIM model elements (Quantity formula). 

The Unit price can be expressed using resources, but it is not necessary. We can also enter fixed unit price 

for cost item. It also contains information about quantity type and measure unit. The Bexel Manager platform 

provides two different ways to connect cost item to BIM model elements. The first way is to link individual 

Cost Items to certain elements of the BIM model. Another method involves automatically linking a Cost Item 

to elements based on specific Query settings. Below are presented both ways. 

18.3.1. CREATING THE COST ITEM  
Select the desired folder structure. → By right-clicking activate a window in which we select New Cost Item. 

→ From New definition. → The Cost Item Definition Editor window will open where in the Code field we 

enter the code of Cost Item. → In the name field we enter the name of cost item. →In the Description 

window, we can enter description, but this is optional. → In the Quantity Type field, we define the desired 

type of quantity. → In the Quantity Unit field, we define the units of measure. → In the Cost field, specify 

the unit price. → Finish the procedure by clicking the OK button.   

Note: We can also create a new Cost Item based on the one we have already made. In this case, choose the 

From Existing Definition option. 
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18.3.2. EDITING THE COST ITEM 
Select the Cost Item you want to change. → Right-clicking activates a window where we select the Edit Cost 

Item Definition item. → The Cost Item Definition Editor window will open, where we enter the desired 

changes. → Finish the procedure by clicking the OK button.   

Note: When editing Cost Item, we have two options: Edit Cost Item and Edit Cost Item Definition. The 

difference between them is that with the Edit Cost Item we can edit only the Code and Description. So, we 

can only change the name and description. With Edit Cost Item Definition, we can change other data. 

18.3.3. COPYING THE COST ITEM 
Select the Cost Item that you want to copy. → By right-clicking, activate a window where we select the Copy 

command. → Select the folder structure where we will copy it. → By right clicking on the selected place, a 

window will be opened where you choose the Paste option.  

18.3.4. CUTTING THE COST ITEM 
Select the Cost Item that you want to cut. → By right-clicking, activate a window where we select the Cut 

command. → Select the folder structure where we will cut it. By right clicking on the selected place, a window 

will be opened where you choose the Paste option.  

18.3.5. DELETING THE COST ITEM 
Select the Cost Item that you want to delete. → By right-clicking, activate a window where we select the 

Delete command. → A notification will pop up asking if we really want to delete this item. → Finish the 

procedure by clicking the OK button.  

Note: Cost Editor palette has two types of the Delete command. The first one is located in the toolbar, where 

all classification systems are listed. It allows deleting of the entire classification system. The Delete command 

that we activate by right-clicking on the Cost Item or Classification Item, allows us to delete only the selected 

items. Both commands are irreversible.  

18.3.6. QUERY  
Using the Query item, we determine how a Cost Item will be linked to the corresponding BIM model element. 

If we want to connect Cost Item and BIM-model elements automatically, we need to define two parameters. 

The first parameter is the Query, which combines the attribute on which the Cost Item will connect with the 

element. The second parameter is the Formula, determines which formula will be used for quantities. 

In the newly created or already existing Cost Item-u we activate the Cost Item Definition Editor. → Open the 

Mappings tab, where Query and Formula are given. → Click on the Change button on the Query item. The 

Element Query Editor window will open, where we define attributes that are base for connection of the Cost 
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Item and the BIM model elements. → Click the Insert Query and then Property Value. → The New Query 

window will open, where we define the attribute name and type. → In the next step, we define the conditions 

of choosing the elements with this attribute.→ Finish the procedure by clicking the OK button.  → When we 

want to enter the desired values in the Formula field, we also click on the Change button. → The Expression 

Editor window will open where we choose the desired formula value. → Finish the procedure by clicking the 

OK button → When Formula and Query are defined, click the OK button. → This completes the process of 

adding the Query item.  

 

18.4. LINKING COST ITEM WITH BIM MODEL ELEMENT 
If we want to build a BIM 5D-model, we need to connect the classification system with BIM-model elements. 

That way we add unit price to individual 3D BIM model elements. We can do this in two different ways. The 

first implies linking each individual part of the building with the appropriate cost item. The other way is to 

automatically connect all cost items together with the corresponding elements of the BIM model. This is 

enabled by using the Query item. 

18.4.1. CONNECTING INDIVIDUAL COST ITEM WITH DEFINED ELEMENT 
Activate the Cost tab located at the top of the screen next to the Settings tab. → Click on the Synchronize 

Database command, and in this way, the newly created classification system will also be displayed on the 
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Cost Items tab. → We activate the Cost Items tab and in the closing window we select the desired 

classification system. →  In the main viewport, mark the element we want to add Cost Item. → Right-click to 

select the appropriate Cost Item in the classification system. → In the open window, select the Assign Cost 

Item(s) command. → Finish the procedure by clicking the OK button.  

 

18.4.2. REMOVING COST ITEM FROM DEFINED ELEMENT 
We activate the Assigned Items tab. → In the main viewport, mark the element from which we want to 

remove the Cost Item. → Click on the Filter by Element Selection command. → A Cost Item which is 

connected to the selected element is displayed, with its location in folder structure. → Right-click the Cost 

Item and select the Delete Assignments command. → A warning will appear, where the entire procedure is 

completed by clicking the YES button.  

18.4.3. AUTOMATIC CONNECTION OF COST ITEM AND BIM MODEL ELEMENT  
Activate the Cost tab, located at the top of the screen in the main toolbar. → Click on the Synchronize 

Database command to determine that the newly created classification system is also visible in the Cost Editor 

palette. → We activate the Cost Editor palette and select the desired classification system in the drop-down 
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window. →  Below, where the classification is listed, select the classification system using the right click and 

select the Auto-Assign Cost Items command. →  Finish the procedure by clicking the OK button.  

 

18.4.4. REMOVING ALL COST ITEMS FROM BIM MODEL ELEMENTS  
If we want to remove the Cost Items that we have linked to the BIM model, we activate the Cost tab and click 

on the Clear All Items command. This procedure deletes all previous Cost Items, which we have linked to BIM 

elements. 

Note: Linking Cost Items to elements of the BIM model is actually the 5D BIM model. When we connect the 

BIM model with cost data, it will be displayed as a 5D simulation in the Schedule Animation tab. To properly 

display the simulations, we should not forget to activate the Schedule Viewer display type.  

 

19. CONSTRUCTION PROGRESS IN THE BEXEL MANAGER PLATFORM 
Created 5D model BIM model can be used to monitor construction progress on construction site. This gives 

us a clear overview of the schedule, possible delays and cash flows during the project implementation. Some 

of the activities in the schedule are not related to model elements. Such activities are called the Default 

Activity. The works related to such activities are entered manually. The progress of the schedule activities, 

which are related to the model elements, can be entered by forming the selection sets.  

19.1. CONSTRUCTION PROGRESS  
In the process of construction monitoring, first we have to copy the existing schedule. → Then we click the 

Progress, which is located on the Schedule Editor palette. → The Schedule Progress Editor window will open, 

where we click on the New button. → The Progress Entry Editor window will open, where in the Range filed, 

we set the period in which we want to monitor the construction process. → Under Start Date we specify the 

start date of the project. → Under Finish Date we define the day to which we want to follow the construction 

process → Click the arrow next to the Add command and select the Planned. → A list of all activities planned 

for the selected period will be displayed. → Select the Marked as Planned option to indicate that all activities 

for the selected period were in line with the schedule. → In this case, in the Last Entered Date field, mark the 
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last entry date. → By doing this, we completed the process of monitoring the construction for the selected 

period, which will also be displayed in the Schedule Progress Editor window.  

 

19.2. ADDING NEW CONSTRUCTION PROGRESS ENTRY  
When we want to add a new period to construction monitoring, we follow the same procedure. → Click on 

the Progress button and activate Schedule Progress Editor. → Then click the New button and specify the 

period in which we want to monitor the construction. → The Progress Entry Editor window will open. → 

Again, define the period in which we want to oversee the construction. → After setting the period, click on 

the Add button and select the Planned item. → The list shows all planned activities during this period. → 

Determine how activities are taking place.→ Finish the procedure by clicking the OK button. → In the end, in 

the Last Entered Date window we define the last day of the previous period, during which we monitored the 

construction. 

19.3. COMPARING THE SCHEDULES 

When we complete the construction tracking process, we return to the Schedule Editor tab and activate the 

Gantt display type. In the Compare with field, choose the original schedule and compare them. Dotted line 

indicates the progress of works and any delay. 
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20. FACILITY MAINTENANCE  
 

Facility Maintenance is a program module that allows us to plan maintenance of the facility. The 6D-BIM 

model involves the inclusion of information to support facilities management and operation to drive better 

business outcomes. Besides the so-called As-built models, it also contains extremely rich register of 

documentation that was used to complete the construction and execution of the project. In addition to the 

6D-BIM model, which contains the entire project documentation, it also includes all the documentation 

necessary for maintaining the facility at the stage of use. This documentation includes evidence, certificates, 

instructions for use, etc. relating to embedded materials, furniture, hardware, electrical and other 

equipment. Then it is connected to individual BIM-models.  

The FM module is located at the bottom of the user interface. The top of the palette contains basic 

commands, while the lower part contains the list of all entered contracts, plans, and entries. If one company 

will carry out more maintenance activities, we will make contract and inside it we will list all planned activities 

in form of plans. We will use entries for all unplanned activities like for example unexpected repairs. 

When we enter all signed contracts and maintenance activities, we can see a list of planned activities for the 

selected period, which may be a month, year or decade. Based on this, we can prepare a maintenance report 

for the selected period. 

 

20.1. FACILITY MAINTENANCE TOOLSET 
 

On the toolbar module, we have standard tools like New for entering a new contracts, plans, and entries. The 

Edit for editing and Delete for deleting individual items. The Export command allows us to export activities 

within a selected period to excel. With Report tool we can create reports for a specific period. Then there are 

the Select Elements and Filter by Element Selection tool that allow us to select and filter the BIM model 

elements that are linked to the plans. Finally, we have Hide Contract Events and Hide Plan Events, that can 

be used if we only want to see Contracts and Plans but not individual events inside them. 

  

20.2. CONTRACT 
 

20.2.1.  ADDING THE CONTRACT 
Activate the Facility Maintenance tab. → Click the arrow next to the New button in the toolbar palette and 

select the Contract item. → The Contract Editor window will open, which contains two commands: General 

and Notes. → First, we define the name of the contract in the Name field. → In the Calendar field, we define 

the calendar type. → In the Start Date field, we define the date when the contract starts. → In the Finish 

Date field, we define the date until the contract is valid. → In the Recurrence Pattern we define the interval 

at which the activity is performed. → Under Type, we define whether the activity of a contract is at a daily, 

weekly, monthly or annual level. → Based on the selected repetition interval, we define when this activity 

will take place. → In the Company Info field, we enter the information about the company which we made 

the contract with. → In the Notes field, we can enter various comments. → Finish the process by clicking the 

Save and Close button.  
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20.3. PLAN  
 

20.3.1. ADDING THE MAINTENANCE PLAN   
Activate the Facility Maintenance tab. → Click on the arrow next to the New button in the toolbar and select 

the Plan command. → The Plan Editor window will open, which contains the General, Notes, Documents and 

Viewports tabs. → First, in the Name field, we define the plan name. → Then in the Assign To field, we define 

who is assigned for the implementation of this activity. → In the Start Date and Finish Date fields, specify the 

period in which the activity is performed. → In the Recurrence Pattern field, we define the repetition interval. 

→ Under Type we define whether the activity of a contract is at a daily, weekly, monthly or annual level.  → 

Based on the selected repetition interval, we define when this activity will repeat. → In the Notes tab, we 

enter various comments. → In the Documents tab we can link documents to this plan.→In the Viewports tab 

we can add screenshots of the BIM elements involved in this activity. →Finish the process by clicking the 

Save and Close button.  
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20.3.2. EDITING THE MAINTENANCE PLAN   
 Select the Plan on the list, so it becomes colored in green. → Click on the Edit command in the toolbar. → 

The Plan Editor window will open, where we can change individual parameters.  

Note: We can also change the plan by highlighting it first. Right-click to activate the drop-down menu and 

select the Edit item. The Plan Editor window will open, where we can change the existing data. In the same 

way we can change the entered contracts.   

20.3.3. DELETING THE MAINTENANCE PLAN   
When we want to delete an individual position, we must first select it. → By clicking on the Delete command 

in the toolbar or in the menu that we activate by right-clicking an item, we can delete the selected item from 

the list. 

Note: The same procedure is used for deleting contracts and entries.   

All entered plans and contracts are listed in the table with the Start and Finish, columns, which tell us when 

the activity will occur. Column Interval represents the repetition interval. The Cost column lists the price of 

the contract. In the Actual Cost column, the actual price of a particular activity is indicated. While the Planned 

Cost column lists the estimated cost of this activity. Prices are valid only for a given period of activity. The 

Note column lists the notes we enter when creating a contract or position  

 

20.4. LINKING THE PLANS TO THE ELEMENTS OF BIM-MODEL 
 

20.4.1. LINKING THE PLANS TO THE ELEMENTS 
 In order to link the plans with building elements of a 

model, we first create the appropriate selection of 

elements and isolate them in the main 3D viewport. → 

Facility Maintenance → Select the desired plan so that it 

becomes colored green. →  By right-clicking, activate the 

menu and select the Link To Selected Elements command.  

20.4.2. UNLINKING THE PLANS FROM THE ELEMENTS 

OF BIM MODEL 
Facility Maintenance → Select the desired item so that it 

becomes colored green. → By right-clicking, activate the 

drop-down menu and select the Unlink From Selected 

Elements command. 

Note: When we use Filter by Element Selection tool by 

clicking on elements in the main 3D viewport, 

corresponding FM plans and contracts will be filtered in 

the FM table.  

 


